summaryrefslogtreecommitdiff
path: root/pcr/rstudio-desktop/PKGBUILD
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2013-04-07 00:46:34 -0400
committerLuke Shumaker <LukeShu@sbcglobal.net>2013-04-07 00:46:34 -0400
commit619b8d955269f2fe74386e98fac07675c8b55352 (patch)
treef3e2610a39c99a7e43bc2b345280b04e398b986a /pcr/rstudio-desktop/PKGBUILD
parent2b04539ac9310541a4e563460aed0cb7715770d2 (diff)
parent7d4e98b2d6f2fd4d42ebb55105bab8a05e34ab94 (diff)
downloadabslibre-619b8d955269f2fe74386e98fac07675c8b55352.tar.gz
abslibre-619b8d955269f2fe74386e98fac07675c8b55352.tar.bz2
abslibre-619b8d955269f2fe74386e98fac07675c8b55352.zip
Merge branch 'master' of ssh://parabolagnulinux.org:1863/srv/git/abslibre
Diffstat (limited to 'pcr/rstudio-desktop/PKGBUILD')
-rw-r--r--pcr/rstudio-desktop/PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/pcr/rstudio-desktop/PKGBUILD b/pcr/rstudio-desktop/PKGBUILD
new file mode 100644
index 000000000..569df2b33
--- /dev/null
+++ b/pcr/rstudio-desktop/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: TDY <tdy@archlinux.info>
+# Contributor: Ben Ward <benjamin.ward@bathspa.org>
+
+pkgname=rstudio-desktop
+pkgver=0.97.332
+_commit=e65a459
+pkgrel=1
+pkgdesc="A powerful and productive user interface for R"
+arch=('i686' 'x86_64')
+url="http://www.rstudio.org/"
+license=('AGPL')
+depends=('r>=2.11.1' 'qtwebkit' 'boost-libs>=1.50' 'shared-mime-info')
+makedepends=('git' 'cmake>=2.8' 'boost>=1.50' 'java-environment' 'apache-ant' 'unzip' 'openssl' 'pam' 'wget')
+install=rstudio.install
+source=($pkgname-$pkgver.tgz::https://github.com/rstudio/rstudio/tarball/v$pkgver)
+md5sums=('0197506486c76ed1bff71a534072e0e9')
+
+build() {
+ cd "$srcdir/rstudio-rstudio-$_commit/dependencies/common"
+ sh install-gwt
+ sh install-dictionaries
+ sh install-mathjax
+
+ rm -rf "$srcdir/rstudio-rstudio-$_commit/build"
+ install -dm755 "$srcdir/rstudio-rstudio-$_commit/build"
+ cd "$srcdir/rstudio-rstudio-$_commit/build"
+ cmake -DRSTUDIO_TARGET=Desktop \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr/lib/rstudio ..
+}
+
+package() {
+ cd "$srcdir/rstudio-rstudio-$_commit/build"
+ make DESTDIR="$pkgdir/" install
+ install -Dm644 ../COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+}
+
+# vim:set ts=2 sw=2 et: