summaryrefslogtreecommitdiff
path: root/pcr/reicast-git/PKGBUILD
diff options
context:
space:
mode:
authorcoadde [Márcio Alexandre Silva Delgado] <coadde@parabola.nu>2015-08-27 16:25:27 -0300
committercoadde [Márcio Alexandre Silva Delgado] <coadde@parabola.nu>2015-08-28 18:37:20 -0300
commit735073aaa33694a683ff306a519371a3ae0c8637 (patch)
tree9dcac9ed89c5fd781b0a5fbfcb8961a11f6c23b8 /pcr/reicast-git/PKGBUILD
parent21b410ad00ddaf49927bf0b8726d3554df8d6c7d (diff)
downloadabslibre-735073aaa33694a683ff306a519371a3ae0c8637.tar.gz
abslibre-735073aaa33694a683ff306a519371a3ae0c8637.tar.bz2
abslibre-735073aaa33694a683ff306a519371a3ae0c8637.zip
pcr/reicast-git: add multiplayer support
Diffstat (limited to 'pcr/reicast-git/PKGBUILD')
-rw-r--r--pcr/reicast-git/PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/pcr/reicast-git/PKGBUILD b/pcr/reicast-git/PKGBUILD
index 7b49b2a69..9cff6bd35 100644
--- a/pcr/reicast-git/PKGBUILD
+++ b/pcr/reicast-git/PKGBUILD
@@ -13,13 +13,12 @@ conflicts=('reicast')
provides=('reicast')
makedepends=('git')
depends=('libgl' 'alsa-plugins' 'libpulse' 'python-evdev' )
-optdepends=('xboxdrv: Userspace gamepad driver for Xbox and Xbox360 gamepads'
- 'antimicro: Graphical program used to map keyboard keys and mouse controls to gamepad buttons')
+optdepends=('xboxdrv: Userspace gamepad driver for Xbox and Xbox360 gamepads')
source=(reicast::"git+https://github.com/reicast/reicast-emulator.git"
- 'enable_x11_keyboard_support.patch'
+ 'enable_multiplayer_support.patch'
'wait_if_two_frames_already_in_flight.patch')
sha256sums=('SKIP'
- '095961538c13208b39ebb0b9d6b6e30c1225f218dcc67239a9d938a23aec601e'
+ '12bfc58e12b3ee79b0c82159cdc70c76a4b6804f5c6986853156602bb0e6beb0'
'4e087844ed22f5a65348e6826444481e14d0409faf8dafb0c6e5284f3f2bd9f7')
pkgver() {
@@ -30,10 +29,12 @@ pkgver() {
prepare () {
cd reicast
- # remove nonfree fp.h header
+ # Remove nonfree fp.h header
rm -v core/deps/libpng/fp.h
- patch -Np1 -i "$srcdir"/enable_x11_keyboard_support.patch
+ # Add Multiplayer support
+ patch -Np1 -i "$srcdir"/enable_multiplayer_support.patch
+
patch -Np1 -i "$srcdir"/wait_if_two_frames_already_in_flight.patch
# Add experimental shadow support: http://github.com/reicast-emulator/issues/94