summaryrefslogtreecommitdiff
path: root/pcr/qemu-user-static-git/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Grapentin <andreas@grapentin.org>2018-03-20 22:14:06 +0100
committerAndreas Grapentin <andreas@grapentin.org>2018-03-20 22:14:06 +0100
commit8897bf11ff6d220568bc24aedd7e868d86f3f0f4 (patch)
tree417a8091fd6ad94b253f088fb8579fb0dc5bc2f7 /pcr/qemu-user-static-git/PKGBUILD
parent35c3c72ff08066ea391aeac4aeb9f3e6fba33009 (diff)
downloadabslibre-8897bf11ff6d220568bc24aedd7e868d86f3f0f4.tar.gz
abslibre-8897bf11ff6d220568bc24aedd7e868d86f3f0f4.tar.bz2
abslibre-8897bf11ff6d220568bc24aedd7e868d86f3f0f4.zip
pcr/qemu-user-static-git: updated to v2.12.0.rc0.r0.gf1a63fcfcd
Diffstat (limited to 'pcr/qemu-user-static-git/PKGBUILD')
-rw-r--r--pcr/qemu-user-static-git/PKGBUILD15
1 files changed, 7 insertions, 8 deletions
diff --git a/pcr/qemu-user-static-git/PKGBUILD b/pcr/qemu-user-static-git/PKGBUILD
index 7761b79c9..53d71a05f 100644
--- a/pcr/qemu-user-static-git/PKGBUILD
+++ b/pcr/qemu-user-static-git/PKGBUILD
@@ -7,16 +7,16 @@ _pkgbase=qemu-git
_gitname=qemu
pkgname=(qemu-user-static-git qemu-user-static-binfmt-git)
pkgdesc="A generic and open source machine emulator and virtualizer. Git version."
-pkgver=v2.11.0.r2577.gc26ef39204
+pkgver=v2.12.0.rc0.r0.gf1a63fcfcd
pkgrel=1
arch=(x86_64)
license=(GPL2 LGPL2.1)
url="http://wiki.qemu.org/"
makedepends=(git pixman-static glib2-static pcre-static python2)
source=(git://git.qemu.org/qemu.git
- 0001-fix-program-invocation-name.patch)
+ 0001-add-binfmt-wrapper.patch)
sha256sums=('SKIP'
- '85a1554cd9ce73f8f7eb8e9dd3cdb884466b4cfed7d28ede62246b46bea932cb')
+ '3fc4f49a43adc22e91c485fa13f3690ed2cfc847751032e4215e6da8ec124a27')
validpgpkeys=('CEACC9E15534EBABB82D3FA03353C9CEF108B584')
case $CARCH in
@@ -36,7 +36,7 @@ prepare() {
cd "${srcdir}/${_gitname}"
sed -i 's/vte-2\.90/vte-2.91/g' configure
- patch -Np1 -i "$srcdir"/0001-fix-program-invocation-name.patch
+ patch -Np1 -i "$srcdir"/0001-add-binfmt-wrapper.patch
# update git submodules
scripts/git-submodule.sh update ui/keycodemapdb dtc
@@ -112,7 +112,9 @@ package_qemu-user-static-git() {
local prog
for prog in "$pkgdir"/usr/bin/*; do
- mv -nT -- "$prog" "${prog%-static}-static"
+ if [[ $prog != *-binfmt ]]; then
+ mv -nT -- "$prog" "${prog%-static}-static"
+ fi
done
}
@@ -143,7 +145,4 @@ package_qemu-user-static-binfmt-git() {
--qemu-path /usr/bin \
--exportdir "$pkgdir"/usr/lib/binfmt.d \
--credential yes
-
- # add the "-static" suffix
- sed -i 's/:[^:]*$/-static&/' -- "$pkgdir"/usr/lib/binfmt.d/*.conf
}