summaryrefslogtreecommitdiff
path: root/pcr/pyutil/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Grapentin <andreas@grapentin.org>2019-02-18 10:35:05 +0100
committerAndreas Grapentin <andreas@grapentin.org>2019-02-18 10:37:16 +0100
commit92c04e61e971b4c129e641b2e5ea2f2036e9cb9f (patch)
treef8bbb93e9d5ac025d97662c3b70b34acdc81adfc /pcr/pyutil/PKGBUILD
parent9320730ec7d9f3808114ab4fedc750d87aa29a16 (diff)
downloadabslibre-92c04e61e971b4c129e641b2e5ea2f2036e9cb9f.tar.gz
abslibre-92c04e61e971b4c129e641b2e5ea2f2036e9cb9f.tar.bz2
abslibre-92c04e61e971b4c129e641b2e5ea2f2036e9cb9f.zip
pcr/python-pyutil: moved from pcr/pyutil and updated
Diffstat (limited to 'pcr/pyutil/PKGBUILD')
-rw-r--r--pcr/pyutil/PKGBUILD34
1 files changed, 0 insertions, 34 deletions
diff --git a/pcr/pyutil/PKGBUILD b/pcr/pyutil/PKGBUILD
deleted file mode 100644
index fbeee059e..000000000
--- a/pcr/pyutil/PKGBUILD
+++ /dev/null
@@ -1,34 +0,0 @@
-# Maintainer (AUR): Nicolas Pouillard <nicolas.pouillard@gmail.com>
-# Contributor (AUR): Peter Simons <simons@cryp.to>
-
-# parabola changes and rationale:
-# no changes.
-
-pkgname=pyutil
-pkgver=2.0.0
-pkgrel=1
-pkgdesc="general-purpose python library (used by tahoe-lafs)"
-arch=('any')
-url='https://pypi.python.org/pypi/pyutil'
-license=('GPL2')
-depends=('python2' 'python2-simplejson' 'zbase32' 'python2-twisted')
-makedepends=('python2-setuptools')
-source=("https://pypi.python.org/packages/source/p/pyutil/pyutil-${pkgver}.tar.gz")
-md5sums=('025a06985691133479500139a3729909')
-
-build(){
- cd "$srcdir/pyutil-$pkgver"
- python2 setup.py build
-}
-
-BUILDENV+=(!check)
-check() {
- cd "$srcdir/pyutil-$pkgver"
- python2 setup.py test
-}
-
-package(){
- cd "$srcdir/pyutil-$pkgver"
- python2 setup.py install --root="$pkgdir" --prefix='/usr' --optimize=1
- rm -r "$pkgdir/usr/pyutil"
-}