summaryrefslogtreecommitdiff
path: root/pcr/python2-ssh/PKGBUILD
diff options
context:
space:
mode:
authorEsteban Carnevale <alfplayer@mailoo.org>2014-10-11 21:32:27 -0300
committerEsteban Carnevale <alfplayer@mailoo.org>2014-10-11 21:32:27 -0300
commit73878e9f6a2b86ebf66cf87ec145dc309c8520c4 (patch)
treeadd2354a374b3acde8a673f9250c3ff8d72d86dd /pcr/python2-ssh/PKGBUILD
parentd2556ce4d528b6a62d31b9f28cd37678f565f956 (diff)
parent4e75bcf04fa2ee23cbdc320bdf04af821616a6ee (diff)
downloadabslibre-73878e9f6a2b86ebf66cf87ec145dc309c8520c4.tar.gz
abslibre-73878e9f6a2b86ebf66cf87ec145dc309c8520c4.tar.bz2
abslibre-73878e9f6a2b86ebf66cf87ec145dc309c8520c4.zip
Merge branch 'master' of git://projects.parabola.nu/abslibre
Diffstat (limited to 'pcr/python2-ssh/PKGBUILD')
-rw-r--r--pcr/python2-ssh/PKGBUILD15
1 files changed, 12 insertions, 3 deletions
diff --git a/pcr/python2-ssh/PKGBUILD b/pcr/python2-ssh/PKGBUILD
index bc4378393..1f2725fd8 100644
--- a/pcr/python2-ssh/PKGBUILD
+++ b/pcr/python2-ssh/PKGBUILD
@@ -1,12 +1,17 @@
+# Maintainer : Aurélien DESBRIÈRES <aurelien@hackers.camp>
+# Contributor: Francois Boulogne <fboulogne at april dot org>
+# Contributor: Francois Boulogne <fboulogne at april dot org>
+
pkgname=python2-ssh
pkgver=1.8.0
-pkgrel=1
+pkgrel=3
pkgdesc="Python SSH2 protocol library"
arch=(any)
url="http://pypi.python.org/pypi/ssh"
license=('LGPL')
depends=('python2' 'pycrypto')
-makedepends=()
+makedepends=('python2-distribute')
+checkdepends=('python2-nose')
provides=()
conflicts=()
replaces=()
@@ -15,10 +20,14 @@ options=(!emptydirs)
install=
source=("http://pypi.python.org/packages/source/s/ssh/ssh-$pkgver.tar.gz")
+check() {
+ cd "$srcdir/ssh-$pkgver"
+ python2 test.py
+}
+
package() {
cd "$srcdir/ssh-$pkgver"
python2 setup.py install --root="$pkgdir/" --optimize=1
install -D -m644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
}
-md5sums=('bc4dd59ec0c7bdf78a3840652cac824e')