summaryrefslogtreecommitdiff
path: root/pcr/python2-pyspf/PKGBUILD
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2017-02-01 02:19:43 -0500
committerLuke Shumaker <lukeshu@sbcglobal.net>2017-02-01 02:28:21 -0500
commitc0909157cb9c2649ebc7fd956093dde5b37dc673 (patch)
tree5d1d6f323046c237758ab5c0289eaea379e786a2 /pcr/python2-pyspf/PKGBUILD
parent15f7c4ab15d58b0c613ea7fe2ee0bb8aa1c660b7 (diff)
downloadabslibre-c0909157cb9c2649ebc7fd956093dde5b37dc673.tar.gz
abslibre-c0909157cb9c2649ebc7fd956093dde5b37dc673.tar.bz2
abslibre-c0909157cb9c2649ebc7fd956093dde5b37dc673.zip
Update pcr/pypolicyd-spf
Diffstat (limited to 'pcr/python2-pyspf/PKGBUILD')
-rw-r--r--pcr/python2-pyspf/PKGBUILD41
1 files changed, 0 insertions, 41 deletions
diff --git a/pcr/python2-pyspf/PKGBUILD b/pcr/python2-pyspf/PKGBUILD
deleted file mode 100644
index 6ee566f51..000000000
--- a/pcr/python2-pyspf/PKGBUILD
+++ /dev/null
@@ -1,41 +0,0 @@
-# Maintainer: Rich Li <rich@dranek.com>
-# Contributor: Filip S. Adamsen <fsa [at] fsadev [dot] com>
-# Contributor: Samed Beyribey <ras0ir AT eventualis DOT org>
-pkgname=python2-pyspf
-_pkgname=pyspf
-pkgver=2.0.9
-pkgrel=1
-pkgdesc="Python 2 implementation of Sender Policy Framework (SPF)"
-arch=('any')
-url="http://bmsi.com/python/milter.html"
-license=('Python')
-depends=('python2-pydns' 'python2' 'python2-ipaddr')
-checkdepends=('python2-yaml' 'python2-authres')
-optdepends=('python2-authres: support Authentication-Results headers')
-#conflicts=('python-pyspf')
-options=(!emptydirs)
-source=(https://pypi.python.org/packages/source/p/$_pkgname/$_pkgname-$pkgver.tar.gz)
-md5sums=('055b36fd9469ea77713cf064727a9c18')
-sha1sums=('a239e8e26a67320a022559f72f7748d3c0575000')
-sha256sums=('e4828f785c935d5d24dcab1e8abe13b57de965219c8e821222e763a27fd423e0')
-
-build() {
- cd "$srcdir/$_pkgname-$pkgver"
- python2 setup.py build
-}
-
-# While 2.0.8 passed tests, 2.0.9 fails six tests
-#check() {
-# # Note that python2-authres, which is normally optional, is required for the tests to finish successfully
-# cd "$srcdir/$_pkgname-$pkgver/test"
-# # Use the SPF from this package, not the system-installed version
-# sed -i -e "s|import spf|sys.path.append('..')\nimport spf|" testspf.py
-# python2 testspf.py
-#}
-
-package() {
- cd "$srcdir/$_pkgname-$pkgver"
- python2 setup.py install --root="$pkgdir" --optimize=1
-}
-
-# vim:set ts=2 sw=2 et: