summaryrefslogtreecommitdiff
path: root/pcr/python2-polib/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-08-27 06:05:47 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-08-27 06:05:47 -0300
commitd73f07b0acf8bae623e1e112a7cb3744a84a92ee (patch)
tree87a2b353ea5229bbe309ea9db9d43bf24e2a6fd8 /pcr/python2-polib/PKGBUILD
parentc001329b017288676a28aa6078bf16ad42e318e9 (diff)
parent0ff008e3c9dcc5ef088f481dfff3dcd121575598 (diff)
downloadabslibre-d73f07b0acf8bae623e1e112a7cb3744a84a92ee.tar.gz
abslibre-d73f07b0acf8bae623e1e112a7cb3744a84a92ee.tar.bz2
abslibre-d73f07b0acf8bae623e1e112a7cb3744a84a92ee.zip
Merge branch 'master' of ssh://lukeshu.com:1863/srv/git/mirror/parabola/abslibre
Diffstat (limited to 'pcr/python2-polib/PKGBUILD')
-rw-r--r--pcr/python2-polib/PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/pcr/python2-polib/PKGBUILD b/pcr/python2-polib/PKGBUILD
new file mode 100644
index 000000000..fc346ec97
--- /dev/null
+++ b/pcr/python2-polib/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Esteban V. Carnevale <evcarnevale@gmail.com>
+
+pkgname=python2-polib
+_pkgname='polib'
+pkgver=0.7.0
+pkgrel=1
+pkgdesc='A library to manipulate gettext files'
+url='http://polib.readthedocs.org/en/latest/index.html'
+arch=('any')
+license=('MIT')
+depends=('python2')
+
+source=("https://bitbucket.org/izi/polib/downloads/polib-${pkgver}.tar.gz")
+md5sums=('958f8f81ade7d2484edc25b3989fe247')
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python2 setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+ install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}