summaryrefslogtreecommitdiff
path: root/pcr/python2-oauth2/PKGBUILD
diff options
context:
space:
mode:
authorNicolás Reynolds <apoyosis@correo.inta.gob.ar>2012-11-14 17:19:48 -0300
committerNicolás Reynolds <apoyosis@correo.inta.gob.ar>2012-11-14 17:19:48 -0300
commitd60b5bd6f778cd9c7ea5bb4412aba9ac101ddf9d (patch)
treebe950fc42ca55687854d5ed90e1c97bb6fa5fd57 /pcr/python2-oauth2/PKGBUILD
parent4886a5f8a3f823a5dedea6d137ab650544cefb9d (diff)
parent762b84f828dc02cc9a70268b178e944469148007 (diff)
downloadabslibre-d60b5bd6f778cd9c7ea5bb4412aba9ac101ddf9d.tar.gz
abslibre-d60b5bd6f778cd9c7ea5bb4412aba9ac101ddf9d.tar.bz2
abslibre-d60b5bd6f778cd9c7ea5bb4412aba9ac101ddf9d.zip
Merge branch 'master' of ssh://gparabola/srv/git/abslibre
Diffstat (limited to 'pcr/python2-oauth2/PKGBUILD')
-rw-r--r--pcr/python2-oauth2/PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/pcr/python2-oauth2/PKGBUILD b/pcr/python2-oauth2/PKGBUILD
new file mode 100644
index 000000000..c58e86f9c
--- /dev/null
+++ b/pcr/python2-oauth2/PKGBUILD
@@ -0,0 +1,20 @@
+# Contributor: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
+# Maintainer : Parabola GNU / Linux-libre Aurelien Desbrieres <aurelien@cwb.io>
+
+pkgname=python2-oauth2
+pkgver=1.5.211
+pkgrel=1
+_libname=${pkgname/python2-/}
+pkgdesc="A fully tested, abstract interface to creating OAuth clients and servers"
+arch=(any)
+url="https://github.com/simplegeo/python-oauth2"
+license=('GPL')
+depends=(python2-httplib2)
+makedepends=(python2-distribute)
+source=(http://pypi.python.org/packages/source/${_libname:0:1}/$_libname/$_libname-$pkgver.tar.gz)
+
+build() {
+ cd "$srcdir/$_libname-$pkgver"
+ python2 setup.py install --root=$pkgdir
+ rm -rf "$pkgdir"/usr/lib/python*/site-packages/tests
+}