summaryrefslogtreecommitdiff
path: root/pcr/python-pygame/PKGBUILD
diff options
context:
space:
mode:
authorcoadde [Márcio Alexandre Silva Delgado] <coadde@parabola.nu>2017-03-28 17:37:13 -0300
committercoadde [Márcio Alexandre Silva Delgado] <coadde@parabola.nu>2017-03-28 17:38:35 -0300
commit274ac753d419a7b04a0aa2009257b4c60950a8bb (patch)
tree52e44d4044bef656eb7a2df9c92f441785d88c0f /pcr/python-pygame/PKGBUILD
parent20db042e03ecff3cf7dc8a5df71af8660d0b2a00 (diff)
downloadabslibre-274ac753d419a7b04a0aa2009257b4c60950a8bb.tar.gz
abslibre-274ac753d419a7b04a0aa2009257b4c60950a8bb.tar.bz2
abslibre-274ac753d419a7b04a0aa2009257b4c60950a8bb.zip
remove python-pygame-hg package and add python-pygame package to [pcr]
Diffstat (limited to 'pcr/python-pygame/PKGBUILD')
-rw-r--r--pcr/python-pygame/PKGBUILD62
1 files changed, 13 insertions, 49 deletions
diff --git a/pcr/python-pygame/PKGBUILD b/pcr/python-pygame/PKGBUILD
index 3714c6531..bb1dca970 100644
--- a/pcr/python-pygame/PKGBUILD
+++ b/pcr/python-pygame/PKGBUILD
@@ -1,66 +1,30 @@
-# $Id: PKGBUILD 249777 2015-10-27 00:15:37Z eric $
+# $Id: PKGBUILD 286997 2017-01-19 20:00:16Z arojas $
# Maintainer (Arch): Eric Bélanger <eric@archlinux.org>
# Maintainer: Márcio Silva <coadde@parabola.nu>
-pkgbase=python-pygame-hg
-pkgname=(python-pygame-hg python2-pygame-hg)
-#hg log -l 1 -b default
-_pkgcmt=3549
-_pkgrev=9886cf74b303
-pkgver=1.9.2b1.$_pkgcmt.$_pkgrev
+pkgbase=python-pygame
+pkgname=python-pygame
+pkgver=1.9.3
pkgrel=1
pkgdesc="Python game library"
arch=('i686' 'x86_64' 'armv7h')
url="http://www.pygame.org/"
license=('LGPL')
-depends=('sdl_mixer' 'sdl_ttf' 'sdl_image' 'portmidi')
-makedepends=('python-setuptools' 'python2-setuptools' 'mercurial')
-source=(pygame-${pkgver}release::hg+https://bitbucket.org/pygame/pygame#revision=$_pkgrev
- pygame-joystick.patch)
-sha1sums=('SKIP'
- '62eb0a3188ef64911b8fab479bd8ff17b153e2f2')
+depends=('sdl_mixer' 'sdl_ttf' 'sdl_image' 'python' 'portmidi')
+makedepends=('python-setuptools')
+source=(https://pypi.io/packages/source/p/pygame/pygame-$pkgver.tar.gz)
+sha1sums=('b3ef126f0baea3bd0986fddebba82b6b13f6f282')
-prepare() {
- cd pygame-${pkgver}release
- patch -p1 -i "${srcdir}/pygame-joystick.patch"
- cd ..
+package_python-pygame() {
+ cd pygame-${pkgver}
- cp -a pygame{,2}-${pkgver}release
-
- cd pygame2-${pkgver}release
- find . -type f -exec sed -i 's#/usr/bin/env python#/usr/bin/env python2#' {} +
-}
-
-package_python-pygame-hg() {
- depends=('sdl_mixer' 'sdl_ttf' 'sdl_image' 'python' 'portmidi')
- provides=('python-pygame')
- conflicts=('python-pygame')
-
- cd pygame-${pkgver}release
python config.py -auto
python setup.py install --root="${pkgdir}" --prefix=/usr
# Copying the examples and tests
- cp -R examples lib/* "${pkgdir}/usr/lib/python3.5/site-packages/pygame"
- cp -R test/* "${pkgdir}/usr/lib/python3.5/site-packages/pygame/tests"
-
-# Fixing permissions
- chmod 644 "${pkgdir}"/usr/include/python3.5m/pygame/*
-}
-
-package_python2-pygame-hg() {
- depends=('sdl_mixer' 'sdl_ttf' 'sdl_image' 'python2' 'portmidi')
- provides=('python2-pygame')
- conflicts=('python2-pygame')
-
- cd pygame2-${pkgver}release
- python2 config.py -auto
- python2 setup.py install --root="${pkgdir}" --prefix=/usr
-
-# Copying the examples and tests
- cp -R examples lib/* "${pkgdir}/usr/lib/python2.7/site-packages/pygame"
- cp -R test/* "${pkgdir}/usr/lib/python2.7/site-packages/pygame/tests"
+ cp -R examples lib/* "${pkgdir}/usr/lib/python3.6/site-packages/pygame"
+ cp -R test/* "${pkgdir}/usr/lib/python3.6/site-packages/pygame/tests"
# Fixing permissions
- chmod 644 "${pkgdir}"/usr/include/python2.7/pygame/*
+ chmod 644 "${pkgdir}"/usr/include/python3.6m/pygame/*
}