summaryrefslogtreecommitdiff
path: root/pcr/pysheng/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@lavabit.com>2012-11-16 21:23:21 -0200
committerAndré Fabian Silva Delgado <emulatorman@lavabit.com>2012-11-16 21:23:21 -0200
commit991e612822b8592e0c981ba2546253a94d7376ea (patch)
treea6e8610655c93cf25b8d06ed53652728769b39d3 /pcr/pysheng/PKGBUILD
parent328e2af1c9921d13ff18d793eabc7067255ccd5c (diff)
parentbf44c9909e79acc33fab15e61f30c2f38279b895 (diff)
downloadabslibre-991e612822b8592e0c981ba2546253a94d7376ea.tar.gz
abslibre-991e612822b8592e0c981ba2546253a94d7376ea.tar.bz2
abslibre-991e612822b8592e0c981ba2546253a94d7376ea.zip
Merge branch 'master' of ssh://parabolagnulinux.org:1863/srv/git/abslibre
Diffstat (limited to 'pcr/pysheng/PKGBUILD')
-rw-r--r--pcr/pysheng/PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/pcr/pysheng/PKGBUILD b/pcr/pysheng/PKGBUILD
new file mode 100644
index 000000000..4cbdf5d38
--- /dev/null
+++ b/pcr/pysheng/PKGBUILD
@@ -0,0 +1,24 @@
+# Contributor: mutlu_inek@yahoo.de
+# Maintainer : Parabola GNU / Linux-libre Aurelien Desbrieres <aurelien@cwb.io>
+
+pkgname=pysheng
+pkgver=0.1
+pkgrel=1
+pkgdesc="CLI and GUI program to download pages from Google Books as PNG images"
+arch=(i686 x86_64)
+url="https://code.google.com/p/pysheng/"
+license=('GPL')
+depends=('python2')
+makedepends=()
+optdepends=('python2-reportlab: GUI')
+provides=()
+conflicts=()
+replaces=()
+options=()
+source=(http://pysheng.googlecode.com/files/$pkgname-$pkgver.tgz)
+
+package() {
+ cd $pkgname-$pkgver
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}
+