summaryrefslogtreecommitdiff
path: root/pcr/postler/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-08-27 06:05:47 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-08-27 06:05:47 -0300
commitd73f07b0acf8bae623e1e112a7cb3744a84a92ee (patch)
tree87a2b353ea5229bbe309ea9db9d43bf24e2a6fd8 /pcr/postler/PKGBUILD
parentc001329b017288676a28aa6078bf16ad42e318e9 (diff)
parent0ff008e3c9dcc5ef088f481dfff3dcd121575598 (diff)
downloadabslibre-d73f07b0acf8bae623e1e112a7cb3744a84a92ee.tar.gz
abslibre-d73f07b0acf8bae623e1e112a7cb3744a84a92ee.tar.bz2
abslibre-d73f07b0acf8bae623e1e112a7cb3744a84a92ee.zip
Merge branch 'master' of ssh://lukeshu.com:1863/srv/git/mirror/parabola/abslibre
Diffstat (limited to 'pcr/postler/PKGBUILD')
-rw-r--r--pcr/postler/PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/pcr/postler/PKGBUILD b/pcr/postler/PKGBUILD
new file mode 100644
index 000000000..b5d624895
--- /dev/null
+++ b/pcr/postler/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer (Arch): Kosava <kosava@archlinux.us>
+
+pkgname=postler
+pkgver=0.1.1
+pkgrel=2
+pkgdesc="Postler is simple desktop mail client built in vala"
+arch=('i686' 'x86_64' 'mips64el')
+url="https://launchpad.net/postler"
+license=('GPL')
+depends=('libwebkit' 'libunique' 'libcanberra' 'libnotify')
+makedepends=('vala-010' 'intltool' 'librsvg' 'gettext' 'python2' 'msmtp')
+optdepends=('dexter: provides contact completion'
+ 'lynx: enables HTML to text conversion'
+ 'libindicate: raise flags on dbus for other components of the desktop')
+install="postler.install"
+source=(http://git.xfce.org/apps/$pkgname/snapshot/$pkgname-$pkgver.tar.bz2 $pkgname.install)
+md5sums=('02e502c9f4a4b92e4ace32d9e268f06d'
+ '7541710086c2b4f45da7268c137ed708')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ export VALAC="/opt/vala-0.10/bin/valac"
+ msg "Patching the buildscript to use python2..."
+ sed -i "s|#!/usr/bin/env python|#!/usr/bin/env python2|g" waf
+ ./waf configure --prefix=/usr --disable-libindicate
+ ./waf build
+ ./waf --destdir=$pkgdir install
+}