summaryrefslogtreecommitdiff
path: root/pcr/poco/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@lavabit.com>2013-02-17 21:17:09 -0200
committerAndré Fabian Silva Delgado <emulatorman@lavabit.com>2013-02-17 21:17:09 -0200
commitd273d650f54b440c123e029370885bd2ac8fb553 (patch)
tree95a61131b190b5fda381019d11b22e8a3b561fe2 /pcr/poco/PKGBUILD
parentc33469d8922906a81f87786084bf024b849ff877 (diff)
parent98a7e894d8347b242611c2cfd44bdb0f81576080 (diff)
downloadabslibre-d273d650f54b440c123e029370885bd2ac8fb553.tar.gz
abslibre-d273d650f54b440c123e029370885bd2ac8fb553.tar.bz2
abslibre-d273d650f54b440c123e029370885bd2ac8fb553.zip
Merge branch 'master' of ssh://parabolagnulinux.org:1863/srv/git/abslibre
Diffstat (limited to 'pcr/poco/PKGBUILD')
-rw-r--r--pcr/poco/PKGBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/pcr/poco/PKGBUILD b/pcr/poco/PKGBUILD
new file mode 100644
index 000000000..dad4788d1
--- /dev/null
+++ b/pcr/poco/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Rodrigo Grumiche Silva <grumiche at integrityit dot com dot br>
+# Contributor: nozog
+# Contributor: davidhjelm
+# Contributor: Ray Kohler <ataraxia937 at gmail dot com>
+# Contributor: Nathan Owe < ndowens04 at gmail dot com>
+
+pkgname=poco
+pkgver=1.4.2p1
+pkgrel=2
+pkgdesc="C++ class libraries for network-centric, portable applications,
+complete edition"
+arch=('i686' 'x86_64' 'mips64el')
+url="http://www.pocoproject.org/"
+license=('custom:boost')
+depends=('unixodbc' 'libmysqlclient' 'openssl')
+makedepends=('gcc' 'make' 'unixodbc' 'libmysqlclient' 'openssl' 'chrpath')
+options=()
+source=(http://downloads.sourceforge.net/poco/$pkgname-$pkgver-all.tar.bz2)
+
+build() {
+ cd $srcdir/$pkgname-$pkgver-all
+ ./configure --prefix=/usr --no-samples --no-tests
+ make
+}
+
+
+package() {
+ cd $srcdir/$pkgname-$pkgver-all
+
+ make DESTDIR=$pkgdir install
+
+ install -Dm644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+
+ #removing rpath information from binaries
+ chrpath -d $pkgdir/usr/bin/cpspc
+ chrpath -d $pkgdir/usr/bin/cpspcd
+ chrpath -d $pkgdir/usr/bin/f2cpspd
+ chrpath -d $pkgdir/usr/bin/f2cpsp
+
+ #removing debugging libraries
+ rm $pkgdir/usr/lib/libPoco*d.so*
+}
+
+md5sums=('752e5f5545377be24ee7c7b6b479fbbe')