summaryrefslogtreecommitdiff
path: root/pcr/perl-iptables-parse/PKGBUILD
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2012-11-15 11:07:44 -0500
committerLuke Shumaker <LukeShu@sbcglobal.net>2012-11-15 11:07:44 -0500
commitceb71fa7012f347bd15179693d2484c1b5418505 (patch)
tree1eca7f8923823f94aa9a6cd295d0c0017c47c059 /pcr/perl-iptables-parse/PKGBUILD
parentb1c72d09dd64bffc2fa820bf0927623efc8a394f (diff)
parentecc0a835e2453a8d44a08883bcd3b3f753ffce47 (diff)
downloadabslibre-ceb71fa7012f347bd15179693d2484c1b5418505.tar.gz
abslibre-ceb71fa7012f347bd15179693d2484c1b5418505.tar.bz2
abslibre-ceb71fa7012f347bd15179693d2484c1b5418505.zip
Merge branch 'master' of ssh://parabolagnulinux.org:1863/srv/git/abslibre
Diffstat (limited to 'pcr/perl-iptables-parse/PKGBUILD')
-rw-r--r--pcr/perl-iptables-parse/PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/pcr/perl-iptables-parse/PKGBUILD b/pcr/perl-iptables-parse/PKGBUILD
new file mode 100644
index 000000000..94fe8e17a
--- /dev/null
+++ b/pcr/perl-iptables-parse/PKGBUILD
@@ -0,0 +1,22 @@
+# Contributor: Weirch Sodora <sodora@gmail.com>
+# Maintainer : Parabola GNU / Linux-libre Aurelien Desbrieres <aurelien@cwb.io>
+
+pkgname=perl-iptables-parse
+pkgver=1.1
+pkgrel=1
+pkgdesc="IPTables::Parse - Perl extension for parsing iptables and ip6tables firewall rulesets"
+arch=('i686' 'x86_64')
+url="http://search.cpan.org/~mrash/IPTables-Parse/"
+license=('GPL' 'PerlArtistic')
+depends=('perl' 'iptables')
+options=('!emptydirs')
+source=(http://search.cpan.org/CPAN/authors/id/M/MR/MRASH/IPTables-Parse-$pkgver.tar.gz)
+
+build() {
+ cd $startdir/src/IPTables-Parse-$pkgver
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+ make install DESTDIR=$startdir/pkg || return 1
+ find $startdir/pkg -name '.packlist' -delete
+ find $startdir/pkg -name '*.pod' -delete
+}