summaryrefslogtreecommitdiff
path: root/pcr/paraboley/PKGBUILD
diff options
context:
space:
mode:
authorAurélien DESBRIÈRES <aurelien@hackers.camp>2016-11-06 17:59:17 +0100
committerAurélien DESBRIÈRES <aurelien@hackers.camp>2016-11-06 17:59:17 +0100
commita34a291bead6c5084eaaf9c3d0a6cfec648b48cf (patch)
tree4dd1a5bff13ce7f6a4fa7d17938f3abeea0afc03 /pcr/paraboley/PKGBUILD
parent8de964793f79d0d8db75729ec74bbfb0df29eea7 (diff)
downloadabslibre-a34a291bead6c5084eaaf9c3d0a6cfec648b48cf.tar.gz
abslibre-a34a291bead6c5084eaaf9c3d0a6cfec648b48cf.tar.bz2
abslibre-a34a291bead6c5084eaaf9c3d0a6cfec648b48cf.zip
Last paraboley version
Diffstat (limited to 'pcr/paraboley/PKGBUILD')
-rw-r--r--pcr/paraboley/PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/pcr/paraboley/PKGBUILD b/pcr/paraboley/PKGBUILD
new file mode 100644
index 000000000..268175879
--- /dev/null
+++ b/pcr/paraboley/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer (Parabola): Aurélien DESBRIÈRES <aurelien@hackers.camp>
+
+_pkgname=paraboley
+pkgname=${_pkgname}-git
+pkgver=6
+pkgrel=1
+pkgdesc="Python script to display system infomation alongside the Parabola GNU / Linux-libre logo."
+arch=('any')
+url="https://projects.parabola.nu/paraboley.git"
+license=('GPL')
+depends=('python')
+makedepends=('git' 'python-distribute')
+optdepends=(
+'python-mpd-git: python libary for mpd interaction',
+'python-logbook-git: for logging'
+'imagemagick: for default screenshot command'
+)
+conflicts=()
+provides=('paraboley')
+source=("git://projects.parabola.nu/paraboley.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd ${_pkgname}
+ git rev-list --count HEAD
+}
+
+package() {
+ cd "$_pkgname"
+ python setup.py install --root=${pkgdir}
+ install -D -m644 COPYING ${pkgdir}/usr/share/licenses/paraboley/COPYING
+}