summaryrefslogtreecommitdiff
path: root/pcr/paraboley/PKGBUILD
diff options
context:
space:
mode:
authorAurélien DESBRIÈRES <aurelien@hackers.camp>2014-06-13 14:01:51 +0200
committerAurélien DESBRIÈRES <aurelien@hackers.camp>2014-06-13 14:01:51 +0200
commit6a56e9dd97b0d1a482f2ce4bede5f8921866985c (patch)
tree8b71b62e32470711918822a57d3e0d772ad7e504 /pcr/paraboley/PKGBUILD
parentc4e51555a57d7c2f9a65f681ac324f7b86d7f39a (diff)
downloadabslibre-6a56e9dd97b0d1a482f2ce4bede5f8921866985c.tar.gz
abslibre-6a56e9dd97b0d1a482f2ce4bede5f8921866985c.tar.bz2
abslibre-6a56e9dd97b0d1a482f2ce4bede5f8921866985c.zip
Paraboley an eye on your system
Diffstat (limited to 'pcr/paraboley/PKGBUILD')
-rw-r--r--pcr/paraboley/PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/pcr/paraboley/PKGBUILD b/pcr/paraboley/PKGBUILD
new file mode 100644
index 000000000..a5f4b8d72
--- /dev/null
+++ b/pcr/paraboley/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer (Parabola) : Aurélien DESBRIÈRES <aurelien@hackers.camp>
+
+pkgname=paraboley
+pkgver=0.1
+pkgrel=1
+pkgdesc="Python script to display system infomation alongside the Parabola GNU / Linux-libre logo."
+arch=('any')
+url="https://github.com/XL04D/paraboley"
+license=('GPL')
+depends=('python')
+makedepends=('git' 'python-distribute')
+optdepends=(
+'python-mpd-git: python libary for mpd interaction',
+'python-logbook-git: for logging'
+'imagemagick: for default screenshot command'
+)
+conflicts=()
+provides=('paraboley')
+source="git://github.com/XL04D/paraboley.git"
+
+pkgver() {
+ cd ${pkgname}
+ git describe --always | sed 's|-|.|g'
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ python setup.py install --root=${pkgdir}
+ install -D -m644 COPYING ${pkgdir}/usr/share/licenses/paraboley/COPYING
+}