summaryrefslogtreecommitdiff
path: root/pcr/papis/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Grapentin <andreas@grapentin.org>2018-12-16 22:28:44 +0100
committerAndreas Grapentin <andreas@grapentin.org>2018-12-16 22:28:44 +0100
commitdd8c36110494df9296c9ad6f04cce32c5cd6c754 (patch)
tree85e270f8cfad6bf1af989ef95f51c8f6ea45422a /pcr/papis/PKGBUILD
parent7d7b9bd27451d7a8b4b1ddc4ab8b321564bd4c18 (diff)
downloadabslibre-dd8c36110494df9296c9ad6f04cce32c5cd6c754.tar.gz
abslibre-dd8c36110494df9296c9ad6f04cce32c5cd6c754.tar.bz2
abslibre-dd8c36110494df9296c9ad6f04cce32c5cd6c754.zip
pcr/papis: updated to 0.7
Diffstat (limited to 'pcr/papis/PKGBUILD')
-rw-r--r--pcr/papis/PKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/pcr/papis/PKGBUILD b/pcr/papis/PKGBUILD
index 5348aa7f6..16a0a8edd 100644
--- a/pcr/papis/PKGBUILD
+++ b/pcr/papis/PKGBUILD
@@ -1,5 +1,5 @@
pkgname="papis"
-pkgver=0.6
+pkgver=0.7
pkgrel=1
pkgdesc="Powerful and highly extensible command-line based document and bibliography manager."
arch=(any)
@@ -22,15 +22,20 @@ depends=("python-setuptools"
"python-pypi-magic"
"python-pylibgen"
"python-urwid"
- "python-habanero")
+ "python-habanero"
+ "python-slugify"
+ "python-click")
source=($pkgname-$pkgver.tar.gz::https://github.com/papis/papis/archive/v$pkgver.tar.gz
- $pkgname-vim-gui-add-notes-edit-key.patch)
-sha256sums=('2cb30ea9451e0a8b081d6ea9153f5220d703a4a49cf58ff0dd909bf249c50f81'
- 'ec7a2ada63b5eac58cc89e0230ef6db3438357c2669b7c0f88e247e0266cbe53')
+ $pkgname-vim-gui-add-notes-edit-key.patch
+ $pkgname-click-0.7.patch::https://github.com/papis/papis/commit/7414634a11c61268a98edd26a4de2d65cb44a28b.patch)
+sha256sums=('77381dfe764aaf1d0add1ed943697085a6c2cd596448681764678ae95490901c'
+ 'ec7a2ada63b5eac58cc89e0230ef6db3438357c2669b7c0f88e247e0266cbe53'
+ '389bb2a6b309f949f1be6ac400f4ea7f80eac2f5a7101d98a0f1e0b8ce2a04d1')
prepare() {
cd "$srcdir/$pkgname-$pkgver"
patch -Np1 -i "$srcdir/$pkgname-vim-gui-add-notes-edit-key.patch"
+ patch -Np1 -i "$srcdir/$pkgname-click-0.7.patch"
}
build () {