summaryrefslogtreecommitdiff
path: root/pcr/otf-stix/PKGBUILD
diff options
context:
space:
mode:
authoraurelien <aurelien@cwb.io>2013-09-23 10:33:22 +0200
committeraurelien <aurelien@cwb.io>2013-09-23 10:33:22 +0200
commit2735c9d273c54b555681f30f5c685998fed7b484 (patch)
treef8172dbea44d1c4751a99a62fb236a14c9d2dc20 /pcr/otf-stix/PKGBUILD
parentd78a32a6ccb8663a62a093b54e947e2efc840fe0 (diff)
parent97f65e06566f3bb15bc7395624017b8e6ca0d043 (diff)
downloadabslibre-2735c9d273c54b555681f30f5c685998fed7b484.tar.gz
abslibre-2735c9d273c54b555681f30f5c685998fed7b484.tar.bz2
abslibre-2735c9d273c54b555681f30f5c685998fed7b484.zip
Merge branch 'master' of ssh://parabolagnulinux.org:1863/srv/git/abslibre
Diffstat (limited to 'pcr/otf-stix/PKGBUILD')
-rw-r--r--pcr/otf-stix/PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/pcr/otf-stix/PKGBUILD b/pcr/otf-stix/PKGBUILD
new file mode 100644
index 000000000..6a9b2d62c
--- /dev/null
+++ b/pcr/otf-stix/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer (Arch): ezzetabi <ezzetabi at gawab dot com>
+# Maintainer (Parabola): Alon Ivtsan <alonivtsan@lavabit.com>
+# taken from https://aur.archlinux.org/packages/otf-stix/
+
+pkgname=otf-stix
+pkgver=1.1.0
+#_pkgver=${pkgver//_/-}
+pkgrel=2
+epoch=2
+pkgdesc='A comprehensive set of fonts that serve the scientific and
+engineering community.'
+arch=('any')
+url="http://www.stixfonts.org"
+license=('Custom: OFL')
+depends=('fontconfig' 'xorg-fonts-encodings' 'xorg-font-utils')
+makedepends=('unzip')
+install=otf-stix.install
+source=("http://downloads.sourceforge.net/stixfonts/STIXv$pkgver.zip"
+'http://www.stixfonts.org/STIXFontLicense2010.txt')
+
+build() {
+ /bin/true
+}
+
+package() {
+ cd "$srcdir"
+
+ install -m755 -d "$pkgdir/usr/share/fonts/OTF"
+ install -m644 Fonts/STIX-General/*.otf "$pkgdir/usr/share/fonts/OTF"
+ install -m644 Fonts/STIX-Word/*.otf "$pkgdir/usr/share/fonts/OTF"
+ install -Dm644 "$srcdir"/STIXFontLicense2010.txt \
+ "$pkgdir"/usr/share/licenses/"$pkgname"/license.txt
+}
+
+md5sums=('e5ebc8ef9b7df0f0bac0fd90bce95295'
+'b1af7bbd3cea93a60bf68cf571ad6cab')
+