summaryrefslogtreecommitdiff
path: root/pcr/octave-communications/PKGBUILD
diff options
context:
space:
mode:
authorAurélien DESBRIÈRES <aurelien@hackers.camp>2014-10-08 20:52:46 +0200
committerAurélien DESBRIÈRES <aurelien@hackers.camp>2014-10-08 20:52:46 +0200
commit93f74bc69ff4e26d7a167db715c5baa508ada89e (patch)
tree805a226890739722f7a8b28581ae930d3b39013f /pcr/octave-communications/PKGBUILD
parentfa5921422d1d79e82c414ca9ba908d87340af8f3 (diff)
downloadabslibre-93f74bc69ff4e26d7a167db715c5baa508ada89e.tar.gz
abslibre-93f74bc69ff4e26d7a167db715c5baa508ada89e.tar.bz2
abslibre-93f74bc69ff4e26d7a167db715c5baa508ada89e.zip
Digital Communications
Diffstat (limited to 'pcr/octave-communications/PKGBUILD')
-rw-r--r--pcr/octave-communications/PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/pcr/octave-communications/PKGBUILD b/pcr/octave-communications/PKGBUILD
new file mode 100644
index 000000000..31f11bb8c
--- /dev/null
+++ b/pcr/octave-communications/PKGBUILD
@@ -0,0 +1,39 @@
+#
+# Maintainer : Aurélien DESBRIÈRES <aurelien@hackers.camp>
+# Contributor : Clemens Buchacher <drizzd@aon.at>
+#
+# You can use the newpkg script from
+# https://github.com/drizzd/octave-forge-archlinux to automatically generate
+# new octave-forge PKGBUILDs or update existing ones. Patches welcome.
+#
+
+_pack=communications
+pkgname=octave-$_pack
+pkgver=1.2.0
+pkgrel=1
+pkgdesc="Digital Communications, Error Correcting Codes (Channel Code), Source Code functions, Modulation and Galois Fields"
+arch=(any)
+url="http://octave.sourceforge.net/$_pack/"
+license=('GPL3')
+groups=('octave-forge')
+depends=('octave>=3.4' 'octave-signal>=1.1.3')
+makedepends=()
+optdepends=()
+backup=()
+options=()
+install=$pkgname.install
+_archive=$_pack-$pkgver.tar.gz
+source=("http://downloads.sourceforge.net/octave/$_archive")
+noextract=("$_archive")
+
+build() {
+ cd "$srcdir"
+ mkdir -p builddir
+ octave -q -f --eval "pkg build -verbose -nodeps builddir $_archive"
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/share/octave/packages"
+ mkdir -p "$pkgdir/usr/lib/octave/packages"
+ cp "$srcdir/builddir/$_archive" "$pkgdir/usr/share/octave/$_pack.tar.gz"
+}