summaryrefslogtreecommitdiff
path: root/pcr/octave-communications/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-10-08 18:18:58 -0200
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-10-08 18:18:58 -0200
commit58c74b2b003f29da380ba81dd5462b58c01582d6 (patch)
tree290ebb83d306cd9d47ea5af7a925350b06ab39f4 /pcr/octave-communications/PKGBUILD
parent77e69ee75cf260af0ade12c13e9f3b164b49d920 (diff)
parent93f74bc69ff4e26d7a167db715c5baa508ada89e (diff)
downloadabslibre-58c74b2b003f29da380ba81dd5462b58c01582d6.tar.gz
abslibre-58c74b2b003f29da380ba81dd5462b58c01582d6.tar.bz2
abslibre-58c74b2b003f29da380ba81dd5462b58c01582d6.zip
Merge branch 'master' of ssh://projects.parabola.nu/~git/abslibre
Diffstat (limited to 'pcr/octave-communications/PKGBUILD')
-rw-r--r--pcr/octave-communications/PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/pcr/octave-communications/PKGBUILD b/pcr/octave-communications/PKGBUILD
new file mode 100644
index 000000000..31f11bb8c
--- /dev/null
+++ b/pcr/octave-communications/PKGBUILD
@@ -0,0 +1,39 @@
+#
+# Maintainer : Aurélien DESBRIÈRES <aurelien@hackers.camp>
+# Contributor : Clemens Buchacher <drizzd@aon.at>
+#
+# You can use the newpkg script from
+# https://github.com/drizzd/octave-forge-archlinux to automatically generate
+# new octave-forge PKGBUILDs or update existing ones. Patches welcome.
+#
+
+_pack=communications
+pkgname=octave-$_pack
+pkgver=1.2.0
+pkgrel=1
+pkgdesc="Digital Communications, Error Correcting Codes (Channel Code), Source Code functions, Modulation and Galois Fields"
+arch=(any)
+url="http://octave.sourceforge.net/$_pack/"
+license=('GPL3')
+groups=('octave-forge')
+depends=('octave>=3.4' 'octave-signal>=1.1.3')
+makedepends=()
+optdepends=()
+backup=()
+options=()
+install=$pkgname.install
+_archive=$_pack-$pkgver.tar.gz
+source=("http://downloads.sourceforge.net/octave/$_archive")
+noextract=("$_archive")
+
+build() {
+ cd "$srcdir"
+ mkdir -p builddir
+ octave -q -f --eval "pkg build -verbose -nodeps builddir $_archive"
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/share/octave/packages"
+ mkdir -p "$pkgdir/usr/lib/octave/packages"
+ cp "$srcdir/builddir/$_archive" "$pkgdir/usr/share/octave/$_pack.tar.gz"
+}