summaryrefslogtreecommitdiff
path: root/pcr/neomutt/PKGBUILD
diff options
context:
space:
mode:
authorOmar Vega Ramos <ovruni@gnu.org.pe>2017-10-18 19:53:11 -0500
committerOmar Vega Ramos <ovruni@gnu.org.pe>2017-10-18 19:53:11 -0500
commitc9915bc1556900000d78ee64ae55a7a6dc8336de (patch)
tree4a28212201fca7831b53b1ec32dcecda9a726eba /pcr/neomutt/PKGBUILD
parent8408416f2e7491f0b1b769b743afb46f335392f4 (diff)
downloadabslibre-c9915bc1556900000d78ee64ae55a7a6dc8336de.tar.gz
abslibre-c9915bc1556900000d78ee64ae55a7a6dc8336de.tar.bz2
abslibre-c9915bc1556900000d78ee64ae55a7a6dc8336de.zip
Removing mit-scheme and neomutt: These packages are in community repo
Diffstat (limited to 'pcr/neomutt/PKGBUILD')
-rw-r--r--pcr/neomutt/PKGBUILD56
1 files changed, 0 insertions, 56 deletions
diff --git a/pcr/neomutt/PKGBUILD b/pcr/neomutt/PKGBUILD
deleted file mode 100644
index b285a1f1d..000000000
--- a/pcr/neomutt/PKGBUILD
+++ /dev/null
@@ -1,56 +0,0 @@
-# Maintainer: Chris Salzberg <chris@dejimata.com>
-# Contributor: Leonidas Spyropoulos <artafinde@gmail.com>
-
-pkgname=neomutt
-pkgver=20170912
-pkgrel=1
-pkgdesc='The New Mutt: powerful text-based mail client with all the best feature patches'
-url='http://www.neomutt.org/'
-license=('GPL')
-validpgpkeys=('86C2397270DD7A561263CA4E5FAF0A6EE7371805') # Richard Russon (flatcap) <rich@flatcap.org>
-source=("https://github.com/neomutt/neomutt/archive/$pkgname-$pkgver.tar.gz"
- "https://github.com/neomutt/neomutt/releases/download/$pkgname-$pkgver/$pkgname-$pkgver.tar.gz.sig")
-sha256sums=('9f0d128fe8dbbbddb67e2b629f8b5e52a9d892f82c735845c1708c14e3046657'
- 'SKIP')
-arch=('i686' 'x86_64')
-depends=('openssl' 'gdbm' 'mime-types' 'libsasl' 'gnupg' 'gpgme' 'libidn' 'krb5' 'notmuch-runtime')
-optdepends=('urlview: for url menu')
-makedepends=('git' 'gnupg' 'libxslt')
-conflicts=('mutt')
-provides=('mutt')
-
-prepare() {
- cd $srcdir
- mv "$pkgname-neomutt-$pkgver" "$pkgname-$pkgver"
- cd "$pkgname-$pkgver"
-
- ./prepare \
- --prefix=/usr \
- --sysconfdir=/etc \
- --enable-debug \
- --enable-pgp \
- --enable-gpgme \
- --enable-notmuch \
- --with-gss=/usr \
- --with-ssl=/usr \
- --with-sasl \
- --with-curses=/usr \
- --with-regex \
- --with-idn \
- --with-gdbm
-}
-
-build() {
- cd "$pkgname-$pkgver"
- make
-}
-
-package() {
- cd "$srcdir/$pkgname-$pkgver"
- # Install the program.
- make DESTDIR="$pkgdir" install
- # Cruft we don't want.
- rm "${pkgdir}"/etc/mime.types{,.dist}
-}
-
-# vim: ft=sh ts=2 sw=2 et