summaryrefslogtreecommitdiff
path: root/pcr/neomutt/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Grapentin <andreas@grapentin.org>2017-10-09 18:21:37 +0200
committerAndreas Grapentin <andreas@grapentin.org>2017-10-09 18:21:37 +0200
commit9112b4415fc5189ccdfe8e80695b62290a1b4125 (patch)
treefb1323963b7296c3d767a97227fc959717c0879a /pcr/neomutt/PKGBUILD
parent1c365c1c2e20cf5c17a42f458a5096523ca8acb7 (diff)
downloadabslibre-9112b4415fc5189ccdfe8e80695b62290a1b4125.tar.gz
abslibre-9112b4415fc5189ccdfe8e80695b62290a1b4125.tar.bz2
abslibre-9112b4415fc5189ccdfe8e80695b62290a1b4125.zip
pcr/neomutt: updated to 20170912
Diffstat (limited to 'pcr/neomutt/PKGBUILD')
-rw-r--r--pcr/neomutt/PKGBUILD28
1 files changed, 13 insertions, 15 deletions
diff --git a/pcr/neomutt/PKGBUILD b/pcr/neomutt/PKGBUILD
index bd10566db..b285a1f1d 100644
--- a/pcr/neomutt/PKGBUILD
+++ b/pcr/neomutt/PKGBUILD
@@ -1,13 +1,17 @@
-# Maintainer (Arch): Chris Salzberg <chris@dejimata.com>
+# Maintainer: Chris Salzberg <chris@dejimata.com>
+# Contributor: Leonidas Spyropoulos <artafinde@gmail.com>
pkgname=neomutt
-pkgver=20170206
+pkgver=20170912
pkgrel=1
pkgdesc='The New Mutt: powerful text-based mail client with all the best feature patches'
url='http://www.neomutt.org/'
license=('GPL')
-source=("https://github.com/neomutt/neomutt/archive/neomutt-$pkgver.tar.gz")
-md5sums=('e3d67be3d63a1fd55c249649dfbed1cb')
+validpgpkeys=('86C2397270DD7A561263CA4E5FAF0A6EE7371805') # Richard Russon (flatcap) <rich@flatcap.org>
+source=("https://github.com/neomutt/neomutt/archive/$pkgname-$pkgver.tar.gz"
+ "https://github.com/neomutt/neomutt/releases/download/$pkgname-$pkgver/$pkgname-$pkgver.tar.gz.sig")
+sha256sums=('9f0d128fe8dbbbddb67e2b629f8b5e52a9d892f82c735845c1708c14e3046657'
+ 'SKIP')
arch=('i686' 'x86_64')
depends=('openssl' 'gdbm' 'mime-types' 'libsasl' 'gnupg' 'gpgme' 'libidn' 'krb5' 'notmuch-runtime')
optdepends=('urlview: for url menu')
@@ -15,24 +19,18 @@ makedepends=('git' 'gnupg' 'libxslt')
conflicts=('mutt')
provides=('mutt')
-build() {
+prepare() {
cd $srcdir
mv "$pkgname-neomutt-$pkgver" "$pkgname-$pkgver"
cd "$pkgname-$pkgver"
- # Configure the build.
- ./prepare \
+ ./prepare \
--prefix=/usr \
--sysconfdir=/etc \
--enable-debug \
--enable-pgp \
--enable-gpgme \
--enable-notmuch \
- --enable-pop \
- --enable-imap \
- --enable-smtp \
- --enable-sidebar \
- --enable-compressed \
--with-gss=/usr \
--with-ssl=/usr \
--with-sasl \
@@ -40,17 +38,17 @@ build() {
--with-regex \
--with-idn \
--with-gdbm
+}
- # Build it!
+build() {
+ cd "$pkgname-$pkgver"
make
}
package() {
cd "$srcdir/$pkgname-$pkgver"
-
# Install the program.
make DESTDIR="$pkgdir" install
-
# Cruft we don't want.
rm "${pkgdir}"/etc/mime.types{,.dist}
}