summaryrefslogtreecommitdiff
path: root/pcr/mycron-git/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@lavabit.com>2012-11-16 21:23:21 -0200
committerAndré Fabian Silva Delgado <emulatorman@lavabit.com>2012-11-16 21:23:21 -0200
commit991e612822b8592e0c981ba2546253a94d7376ea (patch)
treea6e8610655c93cf25b8d06ed53652728769b39d3 /pcr/mycron-git/PKGBUILD
parent328e2af1c9921d13ff18d793eabc7067255ccd5c (diff)
parentbf44c9909e79acc33fab15e61f30c2f38279b895 (diff)
downloadabslibre-991e612822b8592e0c981ba2546253a94d7376ea.tar.gz
abslibre-991e612822b8592e0c981ba2546253a94d7376ea.tar.bz2
abslibre-991e612822b8592e0c981ba2546253a94d7376ea.zip
Merge branch 'master' of ssh://parabolagnulinux.org:1863/srv/git/abslibre
Diffstat (limited to 'pcr/mycron-git/PKGBUILD')
-rw-r--r--pcr/mycron-git/PKGBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/pcr/mycron-git/PKGBUILD b/pcr/mycron-git/PKGBUILD
new file mode 100644
index 000000000..16022bc5f
--- /dev/null
+++ b/pcr/mycron-git/PKGBUILD
@@ -0,0 +1,49 @@
+# Contributor: Dirk Sohler <spam@0x7be.de>
+# Maintainer : Parabola GNU / Linux-libre Aurelien Desbrieres <aurelien@cwb.io>
+
+pkgname=mycron-git
+pkgver=20121116
+pkgrel=1
+pkgdesc='A standards compliant and convenient crontab management system.'
+
+url='https://dev.0x7be.de/mycron'
+arch=('any')
+license=('GPL')
+
+depends=('python>=3.0')
+makedepends=('git')
+
+install=mycron.install
+
+source=('mycron.install')
+sha256sums=('a5406ae03412d3a1aaf6aadb902b4dd40bb6eadb21aa2ffb7c21ae95d656f598')
+
+_gitroot='https://github.com/dsohler/mycron'
+_gitname='master'
+
+build() {
+ cd $srcdir
+ msg "Connecting to GIT server...."
+
+ if [[ -d "$_gitname" ]]; then
+ cd "$_gitname" && git pull origin
+ msg "The local files are updated."
+ else
+ git clone "$_gitroot" "$_gitname"
+ fi
+
+ msg "GIT checkout done or server timeout"
+ msg "Starting build..."
+
+ rm -rf "$srcdir/$_gitname-build"
+ git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
+}
+
+package() {
+ cd "$srcdir/$_gitname-build"
+ install -Dm 755 mycron.py $pkgdir/usr/bin/mycron
+ install -Dm 644 example-config.cfg \
+ $pkgdir/usr/share/doc/mycron/example-config.cfg
+ install -Dm 644 example.crontab \
+ $pkgdir/usr/share/doc/mycron/example.crontab
+}