summaryrefslogtreecommitdiff
path: root/pcr/lightspark-git/PKGBUILD
diff options
context:
space:
mode:
authorbill-auger <mr.j.spam.me@gmail.com>2019-09-22 15:32:10 -0400
committerbill-auger <mr.j.spam.me@gmail.com>2019-09-22 17:33:04 -0400
commitb85f23573b96ea439d9f8bb598cf85d76d2f17c1 (patch)
tree0738b33312a716c18fafeea3406cd148a9d0a1d1 /pcr/lightspark-git/PKGBUILD
parent1d408dde55e2a3e8e8b4292e73822c8a1b31a919 (diff)
downloadabslibre-b85f23573b96ea439d9f8bb598cf85d76d2f17c1.tar.gz
abslibre-b85f23573b96ea439d9f8bb598cf85d76d2f17c1.tar.bz2
abslibre-b85f23573b96ea439d9f8bb598cf85d76d2f17c1.zip
[lightspark][lightspark-git]: replace -git package with stable release
Diffstat (limited to 'pcr/lightspark-git/PKGBUILD')
-rw-r--r--pcr/lightspark-git/PKGBUILD46
1 files changed, 0 insertions, 46 deletions
diff --git a/pcr/lightspark-git/PKGBUILD b/pcr/lightspark-git/PKGBUILD
deleted file mode 100644
index c351a9834..000000000
--- a/pcr/lightspark-git/PKGBUILD
+++ /dev/null
@@ -1,46 +0,0 @@
-# Maintainer (Arch): Daniel Landau <daniel+aur@landau.fi>
-# Contributor (Arch): sekret, mail=$(echo c2VrcmV0QHBvc3Rlby5zZQo= | base64 -d)
-# Contributor (Arch): mmm
-# Contributor (Arch): bslackr <brendan at vastactive dot com>
-# Contributor (Arch): Jan "heftig" Steffens <jan.steffens@gmail.com>
-# Contributor (Arch): Thomas Dziedzic < gostrc at gmail >
-# Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
-_pkgname=lightspark
-pkgname=$_pkgname-git
-pkgver=0.8.0.r123.gda0e6514
-pkgrel=1
-pkgdesc="An open source flash player implementation"
-arch=('i686' 'x86_64')
-url="http://lightspark.sourceforge.net"
-license=('LGPL3')
-depends=('gtk2' 'boost-libs<1.66' 'glew' 'ffmpeg' 'curl' 'desktop-file-utils' 'rtmpdump' 'sdl2_mixer' 'glibmm')
-makedepends=('git' 'cmake' 'nasm' 'llvm' 'boost')
-optdepends=('gnash-gtk: Gnash fallback support')
-provides=("$_pkgname")
-conflicts=("$_pkgname")
-install=$pkgname.install
-source=("$_pkgname::git+https://github.com/lightspark/lightspark.git")
-md5sums=('SKIP')
-
-pkgver() {
- cd "$_pkgname"
- git describe --long --tags | sed -r 's/^lightspark-//;s/([^-]*-g)/r\1/;s/-/./g'
-}
-
-build() {
- cd "$_pkgname"
- cmake \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCOMPILE_PLUGIN=1 \
- -DCMAKE_BUILD_TYPE=Release \
- -DGNASH_EXE_PATH=/usr/bin/gtk-gnash \
- -DAUDIO_BACKEND="pulseaudio sdl"
- make
-}
-
-package() {
- cd "$_pkgname"
- make DESTDIR="$pkgdir/" install
-}
-
-# vim:set ts=2 sw=2 et: