summaryrefslogtreecommitdiff
path: root/pcr/libspatialite/PKGBUILD
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2013-04-22 10:52:18 -0400
committerLuke Shumaker <LukeShu@sbcglobal.net>2013-04-22 10:52:18 -0400
commit908d987dd1dcd4899f8f7f0878514c22ca8048b7 (patch)
tree29bf5986774207c3453044e1f370fb98d2431265 /pcr/libspatialite/PKGBUILD
parent308bfb446305a96dffce945b6c4fb82b10d1b91b (diff)
parent8351d69e64a40d68fa32cfeea227b6fcf7afe974 (diff)
downloadabslibre-908d987dd1dcd4899f8f7f0878514c22ca8048b7.tar.gz
abslibre-908d987dd1dcd4899f8f7f0878514c22ca8048b7.tar.bz2
abslibre-908d987dd1dcd4899f8f7f0878514c22ca8048b7.zip
Merge branch 'master' of ssh://parabolagnulinux.org:1863/srv/git/abslibre
Diffstat (limited to 'pcr/libspatialite/PKGBUILD')
-rw-r--r--pcr/libspatialite/PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/pcr/libspatialite/PKGBUILD b/pcr/libspatialite/PKGBUILD
new file mode 100644
index 000000000..24c775fd8
--- /dev/null
+++ b/pcr/libspatialite/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Brian Galey <bkgaley at gmail dot com>
+# Contributor: Pietro Zambelli <peter.zamb at gmail dot com>
+pkgname=libspatialite
+pkgver=4.0.0
+pkgrel=1
+pkgdesc="SQLite extension to support spatial data types and operations"
+arch=('i686' 'x86_64')
+url="https://www.gaia-gis.it/fossil/libspatialite/index"
+license=('MPL')
+depends=('geos' 'proj' 'sqlite3' 'libfreexl')
+options=('!libtool')
+source=("http://www.gaia-gis.it/gaia-sins/$pkgname-$pkgver.tar.gz")
+md5sums=('8040ce4e39913e7d284675c0f15d270d')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}