summaryrefslogtreecommitdiff
path: root/pcr/libast/PKGBUILD
diff options
context:
space:
mode:
authorNicolás Reynolds <fauno@kiwwwi.com.ar>2012-11-18 17:13:56 -0300
committerNicolás Reynolds <fauno@kiwwwi.com.ar>2012-11-18 17:13:56 -0300
commite5e6eaf7e3cad31a74862656283728197b715178 (patch)
tree2b6c997f1bf5d936019a1dfc741b192208270e1b /pcr/libast/PKGBUILD
parent7eff80609dcc365658c94f899d4a3a298e8fb5dd (diff)
parentdcb01f130dac1b244e0ed9fe0041d92a130ab427 (diff)
downloadabslibre-e5e6eaf7e3cad31a74862656283728197b715178.tar.gz
abslibre-e5e6eaf7e3cad31a74862656283728197b715178.tar.bz2
abslibre-e5e6eaf7e3cad31a74862656283728197b715178.zip
Merge branch 'master' of ssh://gparabola/srv/git/abslibre
Diffstat (limited to 'pcr/libast/PKGBUILD')
-rw-r--r--pcr/libast/PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/pcr/libast/PKGBUILD b/pcr/libast/PKGBUILD
new file mode 100644
index 000000000..ede9ab2ce
--- /dev/null
+++ b/pcr/libast/PKGBUILD
@@ -0,0 +1,33 @@
+# $Id: PKGBUILD 40906 2011-03-01 14:45:04Z andrea $
+# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
+# Contributor: Adam 'battlemidget' Stokes <adam.stokes@gmail.com>
+# Maintainer : Parabola GNU / Linux-libre Aurelien Desbrieres <aurelien@cwb.io>
+
+pkgname=libast
+pkgver=0.7
+pkgrel=3
+pkgdesc="The Library of Assorted Spiffy Things."
+arch=('i686' 'x86_64')
+url="http://eterm.sourceforge.net"
+license=('BSD')
+depends=('imlib2' 'pcre' 'libsm')
+options=('!libtool')
+source=(http://www.eterm.org/download/${pkgname}-${pkgver}.tar.gz LICENSE.txt)
+md5sums=('a9ec3b2da317f35869316e6d9571d296'
+ '97071898559acc4f900ceb6cb9579492')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+
+ ./configure --prefix=/usr --with-x
+ make
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+
+ make prefix=${pkgdir}/usr install
+ install -Dm644 ${srcdir}/LICENSE.txt ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}
+md5sums=('a9ec3b2da317f35869316e6d9571d296'
+ '97071898559acc4f900ceb6cb9579492')