summaryrefslogtreecommitdiff
path: root/pcr/gnash-git/PKGBUILD
diff options
context:
space:
mode:
authorOmar Vega Ramos <ovruni@gnu.org.pe>2016-01-09 12:06:39 -0500
committerOmar Vega Ramos <ovruni@gnu.org.pe>2016-01-09 12:06:39 -0500
commitb03089f7a4056a33b49d7a7a16a44512c4b04940 (patch)
tree3bfa29b350ca3e61e5dc02ebb4408abb9e0d9fb3 /pcr/gnash-git/PKGBUILD
parent3a4ea4ebbfa3ec74446eee90138ee7a410018907 (diff)
downloadabslibre-b03089f7a4056a33b49d7a7a16a44512c4b04940.tar.gz
abslibre-b03089f7a4056a33b49d7a7a16a44512c4b04940.tar.bz2
abslibre-b03089f7a4056a33b49d7a7a16a44512c4b04940.zip
gnash-git-0.8.11.r22311.gf0f66ce-1: updating version
Diffstat (limited to 'pcr/gnash-git/PKGBUILD')
-rw-r--r--pcr/gnash-git/PKGBUILD46
1 files changed, 29 insertions, 17 deletions
diff --git a/pcr/gnash-git/PKGBUILD b/pcr/gnash-git/PKGBUILD
index 6e041e2ce..515d4a1b3 100644
--- a/pcr/gnash-git/PKGBUILD
+++ b/pcr/gnash-git/PKGBUILD
@@ -1,33 +1,41 @@
-# Maintainer: Tim Van den Langenbergh <tmt_vdl@gmx.com>
-# Contributor: Omar Botta <omarbotta@gnulinuxlibre.net>
-# Contributor: Carlos Sanchez <cargabsj175@vegnux.org.ve>
-# Contributor: Frederic Bezies <fredbezies@gmail.com>
+# Maintainer (Arch): Iru Cai <mytbk920423@gmail>
+# Maintainer (Arch): Tim Van den Langenbergh <tmt_vdl@gmx.com>
+# Contributor (Arch): Omar Botta <omarbotta@gnulinuxlibre.net>
+# Contributor (Arch): Carlos Sanchez <cargabsj175@vegnux.org.ve>
+# Contributor (Arch): Frederic Bezies <fredbezies@gmail.com>
+# Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
pkgname=gnash-git
_gitname=gnash
-pkgver=0.8.11.r22276.g939bcfb
+pkgver=0.8.11.r22311.gf0f66ce
pkgrel=1
pkgdesc="The GNU SWF Player based on GameSWF - git development version"
arch=('i686' 'x86_64')
url="http://www.gnu.org/software/gnash/"
license=('GPL3')
-depends=('curl' 'giflib' 'sdl' 'libjpeg' 'libpng' 'libltdl' 'libgl'
- 'glu' 'speex' 'fontconfig' 'cairo' 'ffmpeg' 'jemalloc' 'boost-libs'
+depends=('curl' 'giflib' 'sdl' 'libjpeg' 'libpng' 'libgl'
+ 'glu' 'fontconfig' 'cairo' 'ffmpeg' 'jemalloc' 'boost-libs'
'gtk2' 'libldap' 'hicolor-icon-theme' 'desktop-file-utils' 'gconf'
- 'gtkglext' 'agg')
-makedepends=('mesa' 'xulrunner' 'pkgconfig' 'boost' 'git'
- 'gdk-pixbuf2' 'gdk-pixbuf')
-provides=('gnash-common' 'gnash-gtk' "$_gitname")
-conflicts=('gnash-common' 'gnash-gtk' "$_gitname")
-replaces=('gnash-common' 'gnash-gtk')
+ 'gtkglext' 'agg' 'gdk-pixbuf2')
+makedepends=('mesa' 'xulrunner' 'pkgconfig' 'boost' 'git')
+provides=('gnash-common' 'gnash-gtk' 'gnash')
+conflicts=('gnash-common' 'gnash-gtk' 'gnash')
+replaces=('gnash-common' 'gnash-gtk' 'gnash')
options=('!emptydirs')
install=$_gitname.install
backup=('etc/gnashpluginrc')
-source=("https://repo.parabola.nu/other/$pkgname/$pkgname-$pkgver.tar.gz")
-md5sums=('d771bf518551efedc5593868e0750a25')
+source=('git://git.sv.gnu.org/gnash.git'
+ 'jemalloc_gnash.patch'
+ 'gnash_boost.patch')
+sha256sums=('SKIP'
+ '422aad0cf678f8427b1601e41e6440b3526872b640b6ccd3ab93ae656a9a8c8e'
+ '25ca1554f4c6e06d5a3fe68c37f58c7f63cf05544f14ad0e716452f8a033a095')
-mksource=('git://git.sv.gnu.org/gnash.git')
-mkmd5sums=('SKIP')
+pkgver() {
+ cd $_gitname
+
+ echo "0.8.11.r$(git rev-list --count master).g$(git log -1 --format="%h")"
+}
prepare() {
cd $_gitname
@@ -39,6 +47,10 @@ prepare() {
build() {
cd $_gitname
+ patch -Np1 -i "${srcdir}/jemalloc_gnash.patch"
+ patch -Np1 -i "${srcdir}/gnash_boost.patch"
+ sed -i 's#${JEMALLOC_CONFIG} --cxxflags#${JEMALLOC_CONFIG} --cflags#g' configure
+
./configure \
--prefix=/usr \
--sysconfdir=/etc \