summaryrefslogtreecommitdiff
path: root/pcr/geis/PKGBUILD
diff options
context:
space:
mode:
authorMárcio Alexandre Silva Delgado <coadde@lavabit.com>2013-05-21 04:24:04 -0300
committerMárcio Alexandre Silva Delgado <coadde@lavabit.com>2013-05-21 04:24:04 -0300
commit7e10d47cf04f9a5b3fe819dbbfc9fff8036f04ac (patch)
tree2b51169609d399534f6041adb9fc634dfc00d841 /pcr/geis/PKGBUILD
parente777f99123e62a5547bb816e09a460a065c71755 (diff)
parent89c0af8305046890734eba2969c9b057e0a6bf9a (diff)
downloadabslibre-7e10d47cf04f9a5b3fe819dbbfc9fff8036f04ac.tar.gz
abslibre-7e10d47cf04f9a5b3fe819dbbfc9fff8036f04ac.tar.bz2
abslibre-7e10d47cf04f9a5b3fe819dbbfc9fff8036f04ac.zip
Merge branch 'master' of ssh://parabolagnulinux.org:1863/srv/git/abslibre
Diffstat (limited to 'pcr/geis/PKGBUILD')
-rw-r--r--pcr/geis/PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/pcr/geis/PKGBUILD b/pcr/geis/PKGBUILD
new file mode 100644
index 000000000..629cb9d12
--- /dev/null
+++ b/pcr/geis/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Nicolas Quiénot <niQo @ AUR >
+# Contributor: Xiao-Long Chen <chenxiaolong@cxl.epac.to>
+
+pkgname=geis
+pkgver=2.2.15
+pkgrel=3
+pkgdesc="Implementation of the GEIS (Gesture Engine Interface and Support) interface."
+arch=('i686' 'x86_64')
+url="https://launchpad.net/geis"
+license=('GPL' 'LGPL')
+depends=('grail' 'dbus' 'python-gobject')
+makedepends=('xorg-server-devel')
+provides=('utouch-geis')
+conflicts=('utouch-geis')
+replaces=('utouch-geis')
+options=('!emptydirs' '!libtool')
+source=("http://launchpad.net/${pkgname}/trunk/${pkgver}/+download/${pkgname}-${pkgver}.tar.gz")
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ ## add -Wno-format in CFLAGS see FS#34658
+ CFLAGS="$CFLAGS -Wno-format" ./configure --prefix=/usr --disable-static
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make DESTDIR="${pkgdir}/" install
+}
+
+md5sums=('94c8a08497f5fc22061fb0573ca1e220')