summaryrefslogtreecommitdiff
path: root/pcr/emacs-with-editor-git/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Grapentin <andreas@grapentin.org>2018-02-02 16:24:46 +0100
committerAndreas Grapentin <andreas@grapentin.org>2018-02-02 16:24:46 +0100
commit6a1dd1ce906fc523fa4b775088605de55ad9a372 (patch)
treeceba1abbc775465f5cf505f09e7d5045e6dcf4f7 /pcr/emacs-with-editor-git/PKGBUILD
parent814f59cece8a3d6361a1dd236ce9a5ad02ac3980 (diff)
downloadabslibre-6a1dd1ce906fc523fa4b775088605de55ad9a372.tar.gz
abslibre-6a1dd1ce906fc523fa4b775088605de55ad9a372.tar.bz2
abslibre-6a1dd1ce906fc523fa4b775088605de55ad9a372.zip
pcr/emacs-with-editor-git: added
Diffstat (limited to 'pcr/emacs-with-editor-git/PKGBUILD')
-rw-r--r--pcr/emacs-with-editor-git/PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/pcr/emacs-with-editor-git/PKGBUILD b/pcr/emacs-with-editor-git/PKGBUILD
new file mode 100644
index 000000000..01aad15e5
--- /dev/null
+++ b/pcr/emacs-with-editor-git/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer (AUR): Esben Haabendal <esben@haabendal.dk>
+
+# parabola changes and rationale:
+# - added missing makedepends: git
+
+pkgname=emacs-with-editor-git
+_github_org="magit"
+_github_repo="with-editor"
+pkgver=2.7.1.r0.04d59d6
+pkgrel=1
+pkgdesc="Use the Emacsclient as the $EDITOR of child processes"
+arch=('any')
+url="http://github.com/${_github_org}/${_github_repo}"
+license=('GPL3')
+depends=('emacs>=24.4')
+makedepends=('git')
+provides=('emacs-with-editor')
+conflicts=('emacs-with-editor')
+install="${pkgname}.install"
+source=("git+https://github.com/${_github_org}/${_github_repo}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${_github_repo}"
+ printf "%s" "$(git describe --long | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+build() {
+ cd "$srcdir/${_github_repo}"
+ unset EMACS
+ make EFLAGS="-L /usr/share/emacs/site-lisp -L ${srcdir}/${_gitrepo}/lisp" \
+ lisp info
+}
+
+package() {
+ cd "$srcdir/${_github_repo}"
+ mkdir -p ${pkgdir}/usr/share/emacs/site-lisp
+ install -m 644 with-editor.{el,elc} ${pkgdir}/usr/share/emacs/site-lisp
+ mkdir -p ${pkgdir}/usr/share/info
+ install -m 644 with-editor.info ${pkgdir}/usr/share/info/
+}