summaryrefslogtreecommitdiff
path: root/pcr/emacs-lucid/PKGBUILD
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@lukeshu.com>2018-08-23 02:35:47 -0400
committerLuke Shumaker <lukeshu@lukeshu.com>2018-08-23 02:48:31 -0400
commit73d9bf30b19b737447773f5af2c58193735d834f (patch)
tree4b1381703117204a45f3c57eb07aed32cc73e1fd /pcr/emacs-lucid/PKGBUILD
parentba555b8f56ca527a61654951cd6c529216194491 (diff)
downloadabslibre-73d9bf30b19b737447773f5af2c58193735d834f.tar.gz
abslibre-73d9bf30b19b737447773f5af2c58193735d834f.tar.bz2
abslibre-73d9bf30b19b737447773f5af2c58193735d834f.zip
pcr/emacs-lucid: Update 25.3→26.1
Diffstat (limited to 'pcr/emacs-lucid/PKGBUILD')
-rw-r--r--pcr/emacs-lucid/PKGBUILD42
1 files changed, 26 insertions, 16 deletions
diff --git a/pcr/emacs-lucid/PKGBUILD b/pcr/emacs-lucid/PKGBUILD
index 037fa0292..9a087bbf8 100644
--- a/pcr/emacs-lucid/PKGBUILD
+++ b/pcr/emacs-lucid/PKGBUILD
@@ -1,31 +1,46 @@
-# Maintainer: Luke Shumaker <lukeshu@sbcglobal.net>
+# Maintainer: Luke Shumaker <lukeshu@parabola.nu>
# Maintainer (Arch:emacs): Juergen Hoetzel <juergen@archlinux.org>
# Contributor (Arch:emacs): Renchi Raju <renchi@green.tam.uiuc.edu>
_pkgname=emacs
pkgname=emacs-lucid
-pkgver=25.3
-pkgrel=3.1
+pkgver=26.1
+pkgrel=2
+pkgrel+=.lucid1
pkgdesc="The extensible, customizable, self-documenting real-time display editor"
-arch=('i686' 'x86_64')
+pkgdesc+=", with the Lucid X11 toolkit"
+arch=('x86_64')
+arch+=('i686' 'armv7h')
url="http://www.gnu.org/software/emacs/emacs.html"
license=('GPL3')
depends=('librsvg' 'gpm' 'giflib' 'libxpm' 'libotf' 'm17n-lib' 'hicolor-icon-theme' 'gconf' 'desktop-file-utils' 'alsa-lib' 'libmagick6' 'gnutls')
validpgpkeys=('B29426DEFB07724C3C35E5D36592E9A3A0B0F199' '28D3BED851FDF3AB57FEF93C233587A47C207910')
-source=(ftp://ftp.gnu.org/gnu/emacs/$_pkgname-$pkgver.tar.xz{,.sig})
-sha1sums=('1cb4f39e9c0a3305fd62f936c7c95ff8e2924323'
- 'SKIP')
+source=(ftp://ftp.gnu.org/gnu/emacs/$_pkgname-$pkgver.tar.xz{,.sig}
+ 0001-Ignore-color-fonts-when-using-Xft.patch
+ 0001-Port-FC_COLOR-change-to-older-fontconfig.patch
+ 0001-src-ftfont.c-ftfont_spec_pattern-Fix-whitespace.patch)
+sha1sums=('53c01d987b2613701f42d9f941c2d5225a5874c4'
+ 'SKIP'
+ 'e6b77aadf6c60dfdc1ec6b61d5968e64d959257d'
+ '6b40ad3d8936bfd068398c8d46cb8e0b9501fe64'
+ '51b3e6a2c32be315c9a15c55ca2e97e84d204f32')
-pkgdesc+=", with the Lucid X11 toolkit"
provides=("$_pkgname=$pkgver")
conflicts=("$_pkgname")
-arch+=('armv7h')
+
+prepare() {
+ cd $_pkgname-$pkgver
+ patch -Np1 -i "${srcdir}/0001-Ignore-color-fonts-when-using-Xft.patch"
+ patch -Np1 -i "${srcdir}/0001-Port-FC_COLOR-change-to-older-fontconfig.patch"
+ patch -Np1 -i "${srcdir}/0001-src-ftfont.c-ftfont_spec_pattern-Fix-whitespace.patch"
+}
build() {
cd "$srcdir"/$_pkgname-$pkgver
+ PKG_CONFIG_PATH="/usr/lib/imagemagick6/pkgconfig" \
ac_cv_lib_gif_EGifPutExtensionLast=yes ./configure --prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib \
- --localstatedir=/var --with-x-toolkit=lucid --with-xft \
- --with-modules
+ --localstatedir=/var --with-x-toolkit=lucid --with-xft \
+ --with-modules
make
}
@@ -39,9 +54,4 @@ package() {
# fix user/root permissions on usr/share files
find "$pkgdir"/usr/share/emacs/$pkgver -exec chown root:root {} \;
- # fix perms on /var/games
- chmod 775 "$pkgdir"/var/games
- chmod 775 "$pkgdir"/var/games/emacs
- chmod 664 "$pkgdir"/var/games/emacs/*
- chown -R root:games "$pkgdir"/var/games
}