summaryrefslogtreecommitdiff
path: root/pcr/debhelper/PKGBUILD
diff options
context:
space:
mode:
authorDavid P <megver83@openmailbox.org>2017-04-05 20:20:47 -0300
committerDavid P <megver83@openmailbox.org>2017-04-05 20:20:47 -0300
commit75e16f2bf854b9ff3843d0c75e3079985d209488 (patch)
tree780117488fcc60bd6d112273d6c7ca19fe78a7e7 /pcr/debhelper/PKGBUILD
parent42bab6e8d1ace557be69603ef0a824854f56010c (diff)
downloadabslibre-75e16f2bf854b9ff3843d0c75e3079985d209488.tar.gz
abslibre-75e16f2bf854b9ff3843d0c75e3079985d209488.tar.bz2
abslibre-75e16f2bf854b9ff3843d0c75e3079985d209488.zip
Added some alien's dependencies to [pcr]
Diffstat (limited to 'pcr/debhelper/PKGBUILD')
-rw-r--r--pcr/debhelper/PKGBUILD29
1 files changed, 15 insertions, 14 deletions
diff --git a/pcr/debhelper/PKGBUILD b/pcr/debhelper/PKGBUILD
index 9795a14ea..6a49b06f6 100644
--- a/pcr/debhelper/PKGBUILD
+++ b/pcr/debhelper/PKGBUILD
@@ -1,20 +1,21 @@
-# Maintainer (AUR): Antoine Lubineau <antoine@lubignon.info>
-# Contributor (AUR): Andrei "Garoth" Thorp <garoth@gmail.com>
-# Contributor: Luke Shumaker <lukeshu@sbcglobal.net>
-
-_debrepo=http://ftp.debian.org/debian/pool/main/ # Debian Sid
-debfile() { echo -n "$_debrepo"; echo -n "$@"|sed -r 's@(.).*@\1/&@'; }
+# Maintainer: David P. <megver83@openmailbox.org>
+# Contributor: Justin Vreeland <vreeland.justin@gmail.com>
+# Contributor: Antoine Lubineau <antoine@lubignon.info>
+# Contributor: Charles Pigott <charlespigott@googlemail.com>
+# Contributor: Andrei "Garoth" Thorp <garoth "at the nice" gmail "dot" com>
pkgname=debhelper
-pkgver=9.20120322
+pkgver=10.2.5
pkgrel=1
pkgdesc="A collection of programs that can be used in a debian/rules file to automate common tasks"
arch=('any')
-url="http://packages.debian.org/${pkgname}"
-license='GPL3'
-depends=('binutils' 'dpkg' 'file' 'html2text' 'man-db' 'perl')
-makedepends=('po4a')
-source=(`debfile ${pkgname}`/${pkgname}_$pkgver.tar.gz)
+url="http://anonscm.debian.org/cgit/debhelper/debhelper.git/"
+license=('GPL2' 'GPL3')
+depends=('binutils' 'dpkg>=1.16.2' 'file>=3.23' 'html2text' 'man-db>=2.5.1' 'perl>=5.6.0' 'po-debconf')
+makedepends=('po4a>=0.24' 'man-db>=2.5.1' 'file>=3.23' 'git')
+optdepends=('dh-make')
+source=("git://anonscm.debian.org/debhelper/debhelper.git#tag=debian/$pkgver")
+md5sums=('SKIP')
build() {
cd "$srcdir/$pkgname"
@@ -23,7 +24,7 @@ build() {
package() {
cd "$srcdir/$pkgname"
- make DESTDIR="$pkgdir" install
+ make DESTDIR="$pkgdir/" install
}
-md5sums=('9ea56782e6396a59ec49f45f9c4a603f')
+# vim:set ts=2 sw=2 et: