summaryrefslogtreecommitdiff
path: root/pcr/cowpatty/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-06-11 22:12:54 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-06-11 22:12:54 -0300
commit67320d963187273bd845a938a64460c3ee0b34ec (patch)
treeb9df2cab50cf24e92d5558bb8bf24fa0b07ddac4 /pcr/cowpatty/PKGBUILD
parent78766e0875947c13a97bc958cff89abc5d2f6b1b (diff)
parentd79b0b70c7951aa68158d1957dfe6130cf9bf63e (diff)
downloadabslibre-67320d963187273bd845a938a64460c3ee0b34ec.tar.gz
abslibre-67320d963187273bd845a938a64460c3ee0b34ec.tar.bz2
abslibre-67320d963187273bd845a938a64460c3ee0b34ec.zip
Merge branch 'master' of ssh://projects.parabolagnulinux.org:1863/srv/git/abslibre
Diffstat (limited to 'pcr/cowpatty/PKGBUILD')
-rw-r--r--pcr/cowpatty/PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/pcr/cowpatty/PKGBUILD b/pcr/cowpatty/PKGBUILD
new file mode 100644
index 000000000..c29c53ad8
--- /dev/null
+++ b/pcr/cowpatty/PKGBUILD
@@ -0,0 +1,29 @@
+# Contributor (Arch) : CRT <crt.011@gmail.com>
+# Contributor (Arch) : Sébastien Duquette <ekse.0x@gmail.com>
+# Contributor (Arch) : icarus <icarus.roaming@gmail.com>
+# Contributor (Arch) : Stephane Travostino <stephane.travostino@gmail.com>
+# Maintainer (Parabola) : Aurélien DESBRIÈRES <aurelien@hackers.camp>
+
+pkgname=cowpatty
+pkgver=4.6
+pkgrel=5
+pkgdesc="Wireless WPA/WPA2 PSK handshake cracking utility"
+arch=('i686' 'x86_64')
+url="http://www.wirelessdefence.org/Contents/coWPAttyMain.htm"
+license=('GPL')
+depends=('openssl' 'libpcap')
+options=('docs' '!makeflags')
+source=("http://www.wirelessdefence.org/Contents/Files/cowpatty-$pkgver.tgz")
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make
+ make strip
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" BINDIR="/usr/bin/" install
+ install -D -m644 dict "$pkgdir"/usr/share/cowpatty/dict
+ install -D -m644 COPYING "$pkgdir"/usr/share/licenses/"$pkgname"/COPYING
+}