summaryrefslogtreecommitdiff
path: root/pcr/corosync/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@lavabit.com>2013-05-21 19:02:46 -0300
committerAndré Fabian Silva Delgado <emulatorman@lavabit.com>2013-05-21 19:02:46 -0300
commit60326640ae40c84e9e62855001d03b94b516802d (patch)
tree388952b76054774aa3c507004e448509dd00173d /pcr/corosync/PKGBUILD
parent89c0af8305046890734eba2969c9b057e0a6bf9a (diff)
downloadabslibre-60326640ae40c84e9e62855001d03b94b516802d.tar.gz
abslibre-60326640ae40c84e9e62855001d03b94b516802d.tar.bz2
abslibre-60326640ae40c84e9e62855001d03b94b516802d.zip
corosync: add new package to pcr repo
Diffstat (limited to 'pcr/corosync/PKGBUILD')
-rw-r--r--pcr/corosync/PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/pcr/corosync/PKGBUILD b/pcr/corosync/PKGBUILD
new file mode 100644
index 000000000..e7c019a66
--- /dev/null
+++ b/pcr/corosync/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Eric Renfro <erenfro@gmail.com>
+
+pkgname=corosync
+pkgver=2.1.0
+pkgrel=4
+pkgdesc="Cluster engine for nodal communication systems with additional features for implementing high availability within applications."
+arch=('i686' 'x86_64')
+url="http://www.corosync.org/"
+license=('BSD')
+makedepends=('nss' 'libstatgrab' 'net-snmp' 'libqb')
+depends=('nss' 'libstatgrab' 'net-snmp' 'libqb')
+provides=('corosync=2.1.0')
+conflicts=('corosync1')
+#source=(ftp://ftp:downloads@ftp.corosync.org/downloads/${pkgname}-${pkgver}/${pkgname}-${pkgver}.tar.gz)
+source=("https://github.com/downloads/corosync/corosync/corosync-${pkgver}.tar.gz"
+ "corosync.init"
+ "corosync.service")
+md5sums=('dc5152e6dfdb4638ab544e587884483a'
+ 'fdc3b648f020e165eaa7c3283ce5b9ac'
+ 'abc267226faafc7dc8246634277705ea')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --enable-systemd \
+ --enable-monitoring \
+ --enable-snmp \
+ --enable-dbus \
+ --with-systemddir=/usr/lib/systemd/system
+ make || return 1
+ make DESTDIR="${pkgdir}" install || return 1
+ ## Updated and fixed up systemd service unit and associated start/stop script:
+ cp ${srcdir}/corosync.service ${pkgdir}/usr/lib/systemd/system/corosync.service || return 1
+ cp ${srcdir}/corosync.init ${pkgdir}/usr/share/corosync/corosync || return 1
+}
+