summaryrefslogtreecommitdiff
path: root/pcr/bup/PKGBUILD
diff options
context:
space:
mode:
authorMárcio Alexandre Silva Delgado <coadde@lavabit.com>2012-11-19 16:36:33 -0200
committerMárcio Alexandre Silva Delgado <coadde@lavabit.com>2012-11-19 16:36:33 -0200
commiteb742544b8af9e99209dcf3fac82916df504a5b4 (patch)
tree1e7c8290c9a7a95045398a30a2702ebbfbbb72c4 /pcr/bup/PKGBUILD
parent1c468b79b50fc6c3de26dd08d05010303fadada6 (diff)
parentb8de81d47176637dfd7b9dca164ceea8afe52b56 (diff)
downloadabslibre-eb742544b8af9e99209dcf3fac82916df504a5b4.tar.gz
abslibre-eb742544b8af9e99209dcf3fac82916df504a5b4.tar.bz2
abslibre-eb742544b8af9e99209dcf3fac82916df504a5b4.zip
Merge branch 'master' of ssh://parabolagnulinux.org:1863/srv/git/abslibre
Diffstat (limited to 'pcr/bup/PKGBUILD')
-rw-r--r--pcr/bup/PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/pcr/bup/PKGBUILD b/pcr/bup/PKGBUILD
new file mode 100644
index 000000000..d45d60961
--- /dev/null
+++ b/pcr/bup/PKGBUILD
@@ -0,0 +1,35 @@
+# Contributor: Bram Schoenmakers <me@bramschoenmakers.nl>
+# Contributor: henning mueller <henning@orgizm.net>
+# Maintainer : Parabola GNU / Linux-libre Aurélien Desbrières <aurelien@cwb.io>
+
+# If you'd like to have documentation, please set the variable below to 1.
+# This implies installing pandoc, which in turn depends on many Haskell packages.
+# Which you can build if you wish.
+_havedocs=0
+
+pkgname=bup
+pkgver=0.25rc1
+_pkgver=0.25-rc1
+pkgrel=2
+pkgdesc="Backup tool using git pack files."
+arch=('i686' 'x86_64')
+url="http://github.com/apenwarr/bup"
+license=('GPL')
+depends=('python2-fuse' 'par2cmdline' 'python' 'git')
+[ $_havedocs = 1 ] && makedepends=('haskell-pandoc')
+source=("https://github.com/apenwarr/${pkgname}/archive/${pkgname}-${_pkgver}.tar.gz")
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgname}-${_pkgver}"
+
+ find . -name \*.py | xargs sed -i 's:env python:env python2:'
+ sed -i 's:PYTHON=python:PYTHON=python2:' Makefile
+
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgname}-${_pkgver}"
+ make DESTDIR=$pkgdir install
+}
+