summaryrefslogtreecommitdiff
path: root/pcr/armory/PKGBUILD.old
diff options
context:
space:
mode:
authorAndreas Grapentin <andreas@grapentin.org>2018-01-03 15:36:56 +0100
committerAndreas Grapentin <andreas@grapentin.org>2018-01-03 15:36:56 +0100
commit86d498d37716f0e009e4d8f9308a8aac799bdeab (patch)
tree9f633926ae069ae442d1f3da1e8ac4de4938c78a /pcr/armory/PKGBUILD.old
parent5b25e57cec17385bb7927e5b0b2d4edd50cb2db9 (diff)
downloadabslibre-86d498d37716f0e009e4d8f9308a8aac799bdeab.tar.gz
abslibre-86d498d37716f0e009e4d8f9308a8aac799bdeab.tar.bz2
abslibre-86d498d37716f0e009e4d8f9308a8aac799bdeab.zip
pcr/armory: updated to 0.96.3.99
Diffstat (limited to 'pcr/armory/PKGBUILD.old')
-rw-r--r--pcr/armory/PKGBUILD.old45
1 files changed, 45 insertions, 0 deletions
diff --git a/pcr/armory/PKGBUILD.old b/pcr/armory/PKGBUILD.old
new file mode 100644
index 000000000..0b0482797
--- /dev/null
+++ b/pcr/armory/PKGBUILD.old
@@ -0,0 +1,45 @@
+# Maintainer : Aurélien Desbrières <aurelien@hackers.camp>
+# Contributor : 2bluesc <2bluesc at gmail.com>
+# Contributor : mazzolino <maze+aur at strahlungsfrei.de>
+# Contributor : Pieter Kokx <pieter@kokx.nl>
+
+pkgname=armory
+_pkgname=BitcoinArmory
+pkgver=0.92.3
+_pkgver=0.92.3
+pkgrel=2
+pkgdesc="Python-Based Bitcoin Software"
+arch=('i686' 'x86_64')
+url="https://github.com/etotheipi/BitcoinArmory"
+license=('AGPL3')
+groups=()
+depends=('crypto++' 'swig' 'python2' 'twisted' 'qt4' 'python2-pyqt4' 'python2-bsddb' 'python2-psutil')
+makedepends=('git' 'gcc' 'make')
+provides=('armory')
+conflicts=('armory')
+replaces=()
+backup=()
+options=()
+install=
+source=("run-armory.sh" "build_detect_platform-01.patch" "http://github.com/etotheipi/BitcoinArmory/archive/v$_pkgver.tar.gz")
+noextract=()
+
+build() {
+ cd $srcdir/BitcoinArmory-$_pkgver/
+
+ patch -p0 -i $srcdir//build_detect_platform-01.patch
+
+ make PYVER=python2.7
+}
+
+package() {
+ install -Dm 755 "$srcdir/run-armory.sh" "$pkgdir/usr/bin/armory"
+
+ mkdir -p "$pkgdir/opt"
+ cp -R "$srcdir/$_pkgname-$_pkgver/" "$pkgdir/opt/"
+ mv "$pkgdir/opt/$_pkgname-$_pkgver" "$pkgdir/opt/$_pkgname"
+
+ rm -rf "$pkgdir/opt/$_pkgname/cppForSwig/"
+ rm -rf "$pkgdir/opt/$_pkgname/.git/"
+ rm -rf "$pkgdir/opt/$_pkgname/.gitignore"
+}