summaryrefslogtreecommitdiff
path: root/pcr-testing/qt5-styleplugins/PKGBUILD
diff options
context:
space:
mode:
authorbill-auger <mr.j.spam.me@gmail.com>2020-09-13 07:41:22 -0400
committerbill-auger <mr.j.spam.me@gmail.com>2020-09-13 08:05:09 -0400
commitee4dda8030e73485ce191c636fbf85bbf917f7cb (patch)
treeccfbc8af41973848e9f988c2672970c97741ed5b /pcr-testing/qt5-styleplugins/PKGBUILD
parent6acd17929ecf0b2f5c7e798467c284a0cff19aad (diff)
downloadabslibre-ee4dda8030e73485ce191c636fbf85bbf917f7cb.tar.gz
abslibre-ee4dda8030e73485ce191c636fbf85bbf917f7cb.tar.bz2
abslibre-ee4dda8030e73485ce191c636fbf85bbf917f7cb.zip
[qt5-styleplugins]: rebuild against latest qt5-base
Diffstat (limited to 'pcr-testing/qt5-styleplugins/PKGBUILD')
-rw-r--r--pcr-testing/qt5-styleplugins/PKGBUILD24
1 files changed, 15 insertions, 9 deletions
diff --git a/pcr-testing/qt5-styleplugins/PKGBUILD b/pcr-testing/qt5-styleplugins/PKGBUILD
index 51aab90e6..16adcd271 100644
--- a/pcr-testing/qt5-styleplugins/PKGBUILD
+++ b/pcr-testing/qt5-styleplugins/PKGBUILD
@@ -6,22 +6,28 @@ pkgname=(qt5-styleplugins)
pkgver=5.0.0.20170311
_commit=335dbece103e2cbf6c7cf819ab6672c2956b17b3
pkgdesc='Additional style plugins for Qt5'
-pkgrel=22
+pkgrel=23
arch=(armv7h i686 x86_64)
-url=https://github.com/qt/qtstyleplugins
+url="https://github.com/qt/qtstyleplugins"
license=('LGPL')
depends=('qt5-base' 'gtk2')
-source=(${pkgname}-${_commit}.tar.gz::${url}/archive/${_commit}.tar.gz
- qt-5.15-fix.patch)
-sha512sums=('e8c2d0e9c6b0a47cab04ffd2e9384606638905b63a7c1580f9b629bbcc84ebff19743363ffee3dbd31c3de1dcda684211ad3052932b5aa0081e529afd9cbb14d'
- '5295895bed83dc1a7756282b3e1d7ad34ea368dd51695c4da4a1ba857083c374e968378b3fb00216b8afce77dd0ba0659ff4b342bd313e67d446b7fbdfb60913')
-install='install.sh'
-
+source=(
+ "${pkgname}-${_commit}.tar.gz::${url}/archive/${_commit}.tar.gz"
+ "0001-fix-build-against-Qt-5.15.patch"
+ "0002-fix-gtk2-background.patch"
+)
+sha512sums=(
+ 'e8c2d0e9c6b0a47cab04ffd2e9384606638905b63a7c1580f9b629bbcc84ebff19743363ffee3dbd31c3de1dcda684211ad3052932b5aa0081e529afd9cbb14d'
+ 'f5cedadceb7c4243ba69b5041c6c524223ce742ec9c2c483e706f31e32e9e03e4efb6ed54fa2aada867a7c0145a8f3ec1193377d177c6c77066b5f3ec191e9ce'
+ 'c39b468c93eaada7d49df9547627fbf91d50292523566ef93287ce0e958b29e6c3635f6e77ad42c4f449a062cc63b68e9f2a24c89524165649f776d205fb5382'
+)
prepare() {
cd qtstyleplugins-${_commit}
- patch -p1 < "${srcdir}"/qt-5.15-fix.patch
+ for p in "$srcdir"/*.patch; do
+ patch -p1 < "$p"
+ done
}
build() {