summaryrefslogtreecommitdiff
path: root/pcr-testing/python2-django-postorius/PKGBUILD
diff options
context:
space:
mode:
authorBruno Cichon <ebrasca@librepanther.com>2018-10-01 01:51:29 +0200
committerBruno Cichon <ebrasca@librepanther.com>2018-10-01 01:51:29 +0200
commit9bdcd4c3d22da95e94780454614436082e0eea7d (patch)
treec8755fe8c20be0043d67099bfb357c904c513cff /pcr-testing/python2-django-postorius/PKGBUILD
parent56f955aca6231693fe797de4793f77ed58ab116e (diff)
parent60149d4be1633dd72cba35fcfc29bcf9f117e6fd (diff)
downloadabslibre-9bdcd4c3d22da95e94780454614436082e0eea7d.tar.gz
abslibre-9bdcd4c3d22da95e94780454614436082e0eea7d.tar.bz2
abslibre-9bdcd4c3d22da95e94780454614436082e0eea7d.zip
Merge branch 'master' of git://git.parabola.nu/abslibre/abslibre
Diffstat (limited to 'pcr-testing/python2-django-postorius/PKGBUILD')
-rw-r--r--pcr-testing/python2-django-postorius/PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/pcr-testing/python2-django-postorius/PKGBUILD b/pcr-testing/python2-django-postorius/PKGBUILD
new file mode 100644
index 000000000..35c01a07b
--- /dev/null
+++ b/pcr-testing/python2-django-postorius/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: bill-auger <bill-auger@programmer.net>
+# Maintainer (AUR): Simon Hanna <simon dot hanna AT serve-me DOT info>
+
+pkgname=('python2-django-postorius')
+pkgver=1.2.2
+pkgrel=1
+pkgdesc="A Django app that provides a web user interface to access GNU Mailman"
+arch=(any)
+url=https://gitlab.com/mailman/postorius
+license=('LGPL')
+options=(!emptydirs)
+
+makedepends=('python2-setuptools')
+depends=('python2' 'python2-django-mailman3')
+
+_upstream_name='postorius'
+_release="${_upstream_name}-${pkgver}"
+source=(https://gitlab.com/mailman/${_upstream_name}/-/archive/${pkgver}/${_release}.tar.gz)
+sha256sums=('4299c883a7e1a5044436a3c57a19bf337bd95b4e1b89fe6c66982843622d464e')
+
+
+package()
+{
+ cd "$srcdir/${_release}"
+
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}