summaryrefslogtreecommitdiff
path: root/pcr-testing/liblms7002m/PKGBUILD
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>2018-12-28 11:37:36 +0100
committerDenis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>2018-12-28 17:14:50 +0100
commitaf6a93922eb42bb02fee64165e4e5ab8d69966b9 (patch)
treeeaa397a775c0b0fc3f4696e1f0a6936ca905d17f /pcr-testing/liblms7002m/PKGBUILD
parent0e5d9ac8a50e06f68b2decfd51f1847b51770d6c (diff)
downloadabslibre-af6a93922eb42bb02fee64165e4e5ab8d69966b9.tar.gz
abslibre-af6a93922eb42bb02fee64165e4e5ab8d69966b9.tar.bz2
abslibre-af6a93922eb42bb02fee64165e4e5ab8d69966b9.zip
move xtrx related packages from pcr-testing to pcr
The pakcages have been tested and work on x86_64. I successfully received commercial FM radio stations with it with the following settings: I/O devices configuration: -------------------------- Device: other Device String: xtrx Input Rate: 5000000 Decimation: None Sample rate: 5Msps Banwith: 1.000000 MHz LNO LB: 0.000000 Mhz Input control: -------------- LNA gain: 22 db TIA gain: 9 db PGA gain: 12 db LB gain: 0 db Swap I/Q [] DC Remove [] No limits [] IQ balance [] Freq. correction: 0.0 ppm Antenna: RXL Reset frequency controller digits [] Note that the chosen Antenna is specific to my setup. TODO: - Make the package install in /usr/ instead of /usr/local - Validate the packages on i686 and armv7h - Package the kernel module - Package the other libraries required for the USB3 support. Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
Diffstat (limited to 'pcr-testing/liblms7002m/PKGBUILD')
-rw-r--r--pcr-testing/liblms7002m/PKGBUILD46
1 files changed, 0 insertions, 46 deletions
diff --git a/pcr-testing/liblms7002m/PKGBUILD b/pcr-testing/liblms7002m/PKGBUILD
deleted file mode 100644
index 9a976f901..000000000
--- a/pcr-testing/liblms7002m/PKGBUILD
+++ /dev/null
@@ -1,46 +0,0 @@
-# $id$
-# Contributor: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
-pkgname=liblms7002m
-pkgver=r3.g27fb96f
-pkgrel=2
-pkgdesc="Compact LMS7002 library suitable for MCU"
-url="https://github.com/xtrx-sdr/liblms7002m"
-arch=('armv7h' 'i686' 'x86_64')
-license=('LGPL')
-depends=('python2-cheetah')
-makedepends=('git' 'cmake')
-commit=27fb96fbad28676fa37639062e8990e8cb37c029
-source=("git://github.com/xtrx-sdr/liblms7002m#commit=$commit")
-sha512sums=('SKIP')
-
-pkgver() {
- cd $pkgname
- echo r$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)
-}
-
-prepare() {
- cd "$srcdir/$pkgname"
- sed 's/^python/python2/' -i regs/genenum.sh
-}
-
-build() {
- case "$CARCH" in
- i686) ARCH=i386;;
- x86_64) ARCH=x86_64;;
- arhmv7h) ARCH=armhf;;
- esac
-
- cd "$srcdir/$pkgname"
- mkdir -p build
- cd build
-
- cmake \
- -DFORCE_ARCH=$ARCH \
- ../
- make
-}
-
-package() {
- cd "$srcdir/$pkgname/build/"
- make DESTDIR="${pkgdir}" install
-}