summaryrefslogtreecommitdiff
path: root/pcr-testing/gqrx-xtrx/PKGBUILD
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>2018-12-28 11:37:36 +0100
committerDenis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>2018-12-28 17:14:50 +0100
commitaf6a93922eb42bb02fee64165e4e5ab8d69966b9 (patch)
treeeaa397a775c0b0fc3f4696e1f0a6936ca905d17f /pcr-testing/gqrx-xtrx/PKGBUILD
parent0e5d9ac8a50e06f68b2decfd51f1847b51770d6c (diff)
downloadabslibre-af6a93922eb42bb02fee64165e4e5ab8d69966b9.tar.gz
abslibre-af6a93922eb42bb02fee64165e4e5ab8d69966b9.tar.bz2
abslibre-af6a93922eb42bb02fee64165e4e5ab8d69966b9.zip
move xtrx related packages from pcr-testing to pcr
The pakcages have been tested and work on x86_64. I successfully received commercial FM radio stations with it with the following settings: I/O devices configuration: -------------------------- Device: other Device String: xtrx Input Rate: 5000000 Decimation: None Sample rate: 5Msps Banwith: 1.000000 MHz LNO LB: 0.000000 Mhz Input control: -------------- LNA gain: 22 db TIA gain: 9 db PGA gain: 12 db LB gain: 0 db Swap I/Q [] DC Remove [] No limits [] IQ balance [] Freq. correction: 0.0 ppm Antenna: RXL Reset frequency controller digits [] Note that the chosen Antenna is specific to my setup. TODO: - Make the package install in /usr/ instead of /usr/local - Validate the packages on i686 and armv7h - Package the kernel module - Package the other libraries required for the USB3 support. Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
Diffstat (limited to 'pcr-testing/gqrx-xtrx/PKGBUILD')
-rw-r--r--pcr-testing/gqrx-xtrx/PKGBUILD55
1 files changed, 0 insertions, 55 deletions
diff --git a/pcr-testing/gqrx-xtrx/PKGBUILD b/pcr-testing/gqrx-xtrx/PKGBUILD
deleted file mode 100644
index 83a906f0d..000000000
--- a/pcr-testing/gqrx-xtrx/PKGBUILD
+++ /dev/null
@@ -1,55 +0,0 @@
-# $Id$
-# Maintainer: Kyle Keen <keenerd@gmail.com>
-# Contributor: Dominik Heidler <dheidler@gmail.com>
-# Contributor: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
-
-_pkgname=gqrx
-pkgname=gqrx-xtrx
-pkgver=2.11.1
-pkgrel=2
-pkgdesc="Interactive SDR receiver waterfall for many devices."
-arch=(i686 x86_64)
-url="http://gqrx.dk/"
-license=('GPL')
-depends=('qt5-svg' 'libpulse' 'gnuradio-osmosdr-xtrx' 'libxkbcommon-x11')
-conflicts=('gqrx')
-makedepends=('boost')
-#source=("$_pkgname-$pkgver.tgz::https://github.com/csete/gqrx/archive/v$pkgver.tar.gz")
-source=("https://github.com/csete/gqrx/releases/download/v$pkgver/gqrx-sdr-$pkgver-src.tar.xz")
-md5sums=('e6aa0d72de6420fc4fec00669996eac7')
-
-prepare() {
- cd "$srcdir"
- echo "StartupNotify=false" >> gqrx-sdr-$pkgver/gqrx.desktop
- cp -r gqrx-sdr-$pkgver gqrx-$pkgver-alsa
- cd gqrx-$pkgver-alsa
- sed -i 's/AUDIO_BACKEND = pulse/#&/' gqrx.pro
-}
-
-build() {
- cd "$srcdir/$_pkgname-sdr-$pkgver"
- rm -rf build
- mkdir build
- cd build
- qmake PREFIX=/usr/ ..
- make
- cd "$srcdir/$_pkgname-$pkgver-alsa"
- rm -rf build
- mkdir build
- cd build
- qmake PREFIX=/usr/ ..
- make
-}
-
-package() {
- cd "$srcdir/$_pkgname-sdr-$pkgver"
- install -Dm644 "$_pkgname.desktop" "$pkgdir/usr/share/applications/$_pkgname.desktop"
- install -Dm644 "resources/icons/gqrx.svg" "$pkgdir/usr/share/pixmaps/gqrx.svg"
-
- cd "$srcdir/$_pkgname-sdr-$pkgver/build"
- make install INSTALL_ROOT="$pkgdir"
-
- cd "$srcdir/$_pkgname-$pkgver-alsa/build"
- install -Dm755 gqrx "$pkgdir/usr/bin/gqrx-alsa"
-}
-