summaryrefslogtreecommitdiff
path: root/nonsystemd/libretools/PKGBUILD
diff options
context:
space:
mode:
authorDavid P <megver83@parabola.nu>2018-08-20 23:21:21 -0300
committerDavid P <megver83@parabola.nu>2018-08-20 23:35:45 -0300
commit4307c2b1cdb299cd12403f499cb3fde70781bd1e (patch)
tree0bd340aafb4ee4fe728c9e480ffef08ea96c2ffc /nonsystemd/libretools/PKGBUILD
parentb0798981ede6248dbe84b3b2422ef7051b146878 (diff)
downloadabslibre-4307c2b1cdb299cd12403f499cb3fde70781bd1e.tar.gz
abslibre-4307c2b1cdb299cd12403f499cb3fde70781bd1e.tar.bz2
abslibre-4307c2b1cdb299cd12403f499cb3fde70781bd1e.zip
upgpkg: nonsystemd/libretools 20180815-1.nonsystemd1
Signed-off-by: David P <megver83@parabola.nu>
Diffstat (limited to 'nonsystemd/libretools/PKGBUILD')
-rw-r--r--nonsystemd/libretools/PKGBUILD66
1 files changed, 34 insertions, 32 deletions
diff --git a/nonsystemd/libretools/PKGBUILD b/nonsystemd/libretools/PKGBUILD
index c3a7710af..5d890e681 100644
--- a/nonsystemd/libretools/PKGBUILD
+++ b/nonsystemd/libretools/PKGBUILD
@@ -4,20 +4,49 @@
# Contributor: Márcio Silva <coadde@hyperbola.info>
pkgname=libretools
-pkgver=20180520
+pkgver=20180815
pkgrel=1
pkgrel+=.nonsystemd1
pkgdesc="Programs for Parabola development"
arch=('any')
url="https://git.parabola.nu/packages/libretools.git/"
license=('GPL3' 'GPL2')
+backup=(etc/libretools.conf
+ etc/libretools.d/chroot.conf
+ etc/libretools.d/libredbdiff.conf
+ etc/libretools.d/librefetch.conf)
+install=libretools.install
+conflicts=(devtools libretools-mips64el)
+replaces=(libretools-mips64el)
+depends=(
+ "librelib=$pkgver"
+ 'pacman>=5.1' 'pacman<5.2'
+ arch-install-scripts # `mkarchroot` uses `pacstrap`
+ binutils # `libremakepkg` uses `makepkg` uses `strip`
+ expac # `libredbdiff`
+ fakeroot # `libremakepkg` uses `makepkg` uses `fakeroot`
+ make # `librefetch`
+ openssh # `librerelease`
+ rsync # `librerelease` and `makechrootpkg.sh`
+ chroot-nspawn # chroot-nspawn
+ tokyocabinet # `toru`
+ #namcap # Namcap is currently dissabled in libremakepkg :-(
+ subversion # `diff-unfree`
+ wget # `aur`, optdepend for librelib:`blacklist`
+)
+optdepends=('qemu-user-static-binfmt: To build ARM packages from x86')
makedepends=(ruby-ronn)
-checkdepends=(sh-roundup git expac tokyocabinet)
+checkdepends=(
+ sh-roundup git
+ 'pacman>=5.1' 'pacman<5.2'
+ expac
+ tokyocabinet
+)
source=(https://repo.parabola.nu/other/$pkgname/$pkgname-$pkgver.tar.gz{,.sig}
Remove-systemd-support.patch)
-sha256sums=('784047edc25afbfb294980287b8f04c52cde527f5e1eca9ac0b63f0f89383db9'
+sha256sums=('787907a2cbc9a2aafece5e31543a93c17ca91aa6a0b714e0c6bc158df75d9b2a'
'SKIP'
- '6042a1f468b5a9969f74069b19e643746bbec739cd28d066c3c3b7d96260e43e')
+ '4257e7c5383df8c322d79f8e601893f71eeccbd1b9ceac76c8ebbc90fb609875')
validpgpkeys=('99195DD3BB6FE10A2F36ED8445698744D4FFBFC9') # Luke Shumaker
build() {
@@ -35,34 +64,7 @@ check() {
SUDO_USER= make check TESTENVFLAGS='--no-network --no-sudo'
}
-package_libretools() {
- backup=(etc/libretools.conf
- etc/libretools.d/chroot.conf
- etc/libretools.d/libredbdiff.conf
- etc/libretools.d/librefetch.conf)
- install=libretools.install
- conflicts=(devtools libretools-mips64el)
- replaces=(libretools-mips64el)
-
- depends=(
- "librelib=$pkgver"
- "xbs=$pkgver" # `createworkdir`, `librestage`
- 'pacman>=5.0.1-2.parabola4' 'pacman<5.1'
- arch-install-scripts # `mkarchroot` uses `pacstrap`
- expac # `libredbdiff`
- make # `librefetch`
- openssh # `librerelease`
- rsync # `librerelease` and `makechrootpkg.sh`
- chroot-nspawn # chroot-nspawn
- tokyocabinet # `toru`
- #namcap # Namcap is currently dissabled in libremakepkg :-(
- #subversion # `diff-unfree` # ignore because of xbs
- wget # `aur`, optdepend for librelib:`blacklist`
- )
- optdepends=(
- 'qemu-user-static-binfmt: To build ARM packages from x86'
- )
-
+package() {
cd "$srcdir/$pkgbase-$pkgver"
make install-libretools DESTDIR="$pkgdir"
}