summaryrefslogtreecommitdiff
path: root/nonsystemd/filesystem/PKGBUILD
diff options
context:
space:
mode:
authorDavid P <megver83@parabola.nu>2018-05-11 16:23:48 -0300
committerDavid P <megver83@parabola.nu>2018-05-11 16:23:48 -0300
commitce3823eb663c173540da08bf4b2097942935e559 (patch)
tree33820e1770e5bb942aa57fe5d6aee4a71f1dbca2 /nonsystemd/filesystem/PKGBUILD
parentb64af43366d391e9a960763ebab37dbbd70ded10 (diff)
downloadabslibre-ce3823eb663c173540da08bf4b2097942935e559.tar.gz
abslibre-ce3823eb663c173540da08bf4b2097942935e559.tar.bz2
abslibre-ce3823eb663c173540da08bf4b2097942935e559.zip
nonsystemd/filesystem: add package
Signed-off-by: David P <megver83@parabola.nu>
Diffstat (limited to 'nonsystemd/filesystem/PKGBUILD')
-rw-r--r--nonsystemd/filesystem/PKGBUILD127
1 files changed, 127 insertions, 0 deletions
diff --git a/nonsystemd/filesystem/PKGBUILD b/nonsystemd/filesystem/PKGBUILD
new file mode 100644
index 000000000..58dbb8f1a
--- /dev/null
+++ b/nonsystemd/filesystem/PKGBUILD
@@ -0,0 +1,127 @@
+# $Id: PKGBUILD 291699 2017-03-26 22:06:04Z seblu $
+# Maintainer (Arch): Sébastien Luttringer
+# Contributor (Arch): Tom Gundersen <teg@jklm.no>
+# Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
+# Contributor: Nicolás Reynolds <fauno@kiwwwi.com.ar>
+
+pkgname=filesystem
+pkgver=2018.1
+pkgrel=2.parabola2
+pkgrel+=.nonsystemd2
+pkgdesc='Base Parabola GNU/Linux-libre files'
+arch=('i686' 'x86_64' 'armv7h')
+license=('GPL')
+url='https://www.parabola.nu'
+groups=('base-openrc')
+depends=('iana-etc')
+provides=("filesystem=$pkgver" filesystem-nosystemd)
+replaces=(filesystem-parabola filesystem-nosystemd)
+conflicts=(${conflicts[@]})
+backup=('etc/crypttab' 'etc/fstab' 'etc/group' 'etc/gshadow' 'etc/host.conf'
+ 'etc/hosts' 'etc/issue' 'etc/ld.so.conf' 'etc/motd' 'etc/nsswitch.conf'
+ 'etc/passwd' 'etc/profile' 'etc/resolv.conf' 'etc/securetty'
+ 'etc/shadow' 'etc/shells')
+source=('crypttab' 'fstab' 'group' 'gshadow' 'host.conf' 'hosts'
+ 'issue' 'ld.so.conf' 'locale.sh' 'motd' 'nsswitch.conf' 'os-release'
+ 'passwd' 'profile' 'resolv.conf' 'securetty' 'shadow' 'shells'
+ 'sysusers' 'tmpfiles')
+sha256sums=('e03bede3d258d680548696623d5979c6edf03272e801a813c81ba5a5c64f4f82'
+ 'e54626e74ed8fee4173b62a545ab1c3a3a069e4217a0ee8fc398d9933e9c1696'
+ '244f0718ee2a9d6862ae59d6c18c1dd1568651eada91a704574fa527fbac2b3a'
+ '90d879374f77bac47f132164c1e7fc4892e994ff1d1ac376efa0c1c26ea37273'
+ '4d7b647169063dfedbff5e1e22cee77bd1a4183dbcfd5e802e68939da4bbf733'
+ 'd9cd8a77d9e0aa5e90d7f4ed74c8745c17b525e720e28e4c44364150003c35f9'
+ '3ad448c78cab733759ae3365620504b1444e854effd066f1c7174652f046ebe1'
+ 'dad04a370e488aa85fb0a813a5c83cf6fd981ce01883fc59685447b092de84b5'
+ '8ca2d8eef6fb5143c9ef7e9174ccfef59ac7ad2deee243574cd10c763156cc10'
+ 'e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855'
+ 'aa4dc5b2374fb32863e3bc1ce20a2de2d34fe4eed1cd63c599bc82fab21463cc'
+ '463dbccba0275ee80c532755c7048cb9ded83658a33a82f344aaf1520704f2ac'
+ '5e06477834f51abf42ea4e8dc199632afc6afbfd8c44354685a271e9a48d2c0a'
+ '5da078777cda24e4df697e2928451723f2303bfdbb2ce9551c822188c7945d25'
+ '5557d8e601b17a80d1ea7de78a9869be69637cb6a02fbfe334e22fdf64e61d4c'
+ 'd88be2b45b43605ff31dd83d6a138069b6c2e92bc8989b7b9ab9eba8da5f8c7b'
+ '8ce994663d7588143ad7ed4441b07f468f4f7d3590164dd73ddfa3ea307ece8e'
+ 'c390b31fffc4a2b5d78ae8c89f5317aadef1f71baac09cfb467b675db1406d61'
+ 'ed5c607898391b2aab83a0f45e58c53ed9853b56c5f8892bb2ca24b771603b52'
+ '618ac097441c1f2daffc9967e5c3cd18ea8866f776db62d04bf401c53907b1c9')
+
+package() {
+ cd "$pkgdir"
+
+ # setup root filesystem
+ for d in boot dev etc home mnt usr var opt srv/http run; do
+ install -d -m755 $d
+ done
+ install -d -m555 proc
+ install -d -m555 sys
+ install -d -m0750 root
+ install -d -m1777 tmp
+ # vsftpd won't run with write perms on /srv/ftp
+ # ftp (uid 14/gid 11)
+ install -d -m555 -g 11 srv/ftp
+
+ # setup /etc and /usr/share/factory/etc
+ install -d etc/{ld.so.conf.d,skel,profile.d} usr/share/factory/etc
+ for f in fstab group host.conf hosts issue ld.so.conf motd nsswitch.conf \
+ passwd resolv.conf securetty shells profile; do
+ install -m644 "$srcdir"/$f etc/
+ install -m644 "$srcdir"/$f usr/share/factory/etc/
+ done
+ ln -s ../proc/self/mounts etc/mtab
+ for f in gshadow shadow crypttab; do
+ install -m600 "$srcdir"/$f etc/
+ install -m600 "$srcdir"/$f usr/share/factory/etc/
+ done
+ touch etc/parabola-release
+ ln -sv parabola-release etc/arch-release
+ install -m755 "$srcdir"/locale.sh etc/profile.d/locale.sh
+ install -Dm644 "$srcdir"/os-release usr/lib/os-release
+ ln -s ../usr/lib/os-release etc/os-release
+
+ # setup /var
+ for d in cache local opt log/old lib/misc empty; do
+ install -d -m755 var/$d
+ done
+ install -d -m1777 var/{tmp,spool/mail}
+
+ # allow setgid games (gid 50) to write scores
+ install -d -m775 -g 50 var/games
+ ln -s spool/mail var/mail
+ ln -s ../run var/run
+ ln -s ../run/lock var/lock
+
+ # setup /usr hierarchy
+ for d in bin include lib share/misc src; do
+ install -d -m755 usr/$d
+ done
+ for d in {1..8}; do
+ install -d -m755 usr/share/man/man$d
+ done
+
+ # add lib symlinks
+ ln -s usr/lib lib
+ [[ $CARCH = 'x86_64' ]] && {
+ ln -s usr/lib lib64
+ ln -s lib usr/lib64
+ }
+
+ # add bin symlinks
+ ln -s usr/bin bin
+ ln -s usr/bin sbin
+ ln -s bin usr/sbin
+
+ # setup /usr/local hierarchy
+ for d in bin etc games include lib man sbin share src; do
+ install -d -m755 usr/local/$d
+ done
+ ln -s ../man usr/local/share/man
+
+ # setup sysusers
+ install -D -m644 "$srcdir"/sysusers usr/lib/sysusers.d/parabola.conf
+ ln -sv parabola.conf usr/lib/sysusers.d/arch.conf
+
+ # setup tmpfiles
+ install -D -m644 "$srcdir"/tmpfiles usr/lib/tmpfiles.d/parabola.conf
+ ln -sv parabola.conf usr/lib/tmpfiles.d/arch.conf
+}