summaryrefslogtreecommitdiff
path: root/nonprism/openshot-nonprism/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-08-26 22:12:00 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-08-26 22:12:00 -0300
commite3ef7422ec8daa79e8dcc62d0304f09c95cb8cec (patch)
tree3e16bd19af53d2e54926f2fda57d06a2087c96ff /nonprism/openshot-nonprism/PKGBUILD
parentee64fe57f2fee41d5f0af229306879b4f1b0cee8 (diff)
downloadabslibre-e3ef7422ec8daa79e8dcc62d0304f09c95cb8cec.tar.gz
abslibre-e3ef7422ec8daa79e8dcc62d0304f09c95cb8cec.tar.bz2
abslibre-e3ef7422ec8daa79e8dcc62d0304f09c95cb8cec.zip
remove libre suffix on bitlbee and openshot nonprism packages
Diffstat (limited to 'nonprism/openshot-nonprism/PKGBUILD')
-rw-r--r--nonprism/openshot-nonprism/PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/nonprism/openshot-nonprism/PKGBUILD b/nonprism/openshot-nonprism/PKGBUILD
new file mode 100644
index 000000000..171cbc10d
--- /dev/null
+++ b/nonprism/openshot-nonprism/PKGBUILD
@@ -0,0 +1,34 @@
+# $Id: PKGBUILD 97284 2013-09-16 08:04:43Z bluewind $
+# Maintainer (Arch): Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor (Arch): Asa Marco <marcoasa90[at]gmail[.]com>
+# Maintainer: André Silva <emulatorman@parabola.nu>
+
+_pkgname=openshot
+pkgname=openshot-nonprism
+pkgver=1.4.3
+pkgrel=3
+pkgdesc="a free, non-linear video editor for GNU/Linux based on MLT framework, without nonfree faac recommendation and Youtube uploader support"
+arch=('any')
+url="http://www.openshotvideo.com/"
+license=('GPL')
+depends=('mlt-python-bindings' 'pygoocanvas' 'sdl' 'librsvg' 'mplayer'
+ 'pyxdg' 'pygtk' 'python2-httplib2' 'python2-pillow')
+optdepends=('dvgrab: for IEEE digital sources'
+ 'libquicktime' 'libavc1394' 'jack' 'jack-rack' 'ladspa')
+replaces=("${_pkgname}" "${_pkgname}-libre" "${_pkgname}-parabola")
+conflicts=("${_pkgname}" "${_pkgname}-libre" "${_pkgname}-parabola")
+provides=(${_pkgname}=${pkgver})
+install=openshot.install
+source=(http://launchpad.net/openshot/${pkgver%.*}/$pkgver/+download/$_pkgname-$pkgver.tar.gz
+ nonprism.patch)
+md5sums=('5ec82a7e8b7700ee4a359458aedf19e9'
+ '0b8ade6f6332d1ef9c6c153647953df7')
+prepare() {
+ cd $srcdir/$_pkgname-$pkgver
+ patch -Np1 -i $srcdir/nonprism.patch
+}
+
+package() {
+ cd $srcdir/$_pkgname-$pkgver
+ python2 setup.py install --root=$pkgdir/ --optimize=1
+}