summaryrefslogtreecommitdiff
path: root/nonprism/kipi-plugins/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2017-01-11 00:34:30 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2017-01-11 00:37:49 -0300
commit1686b7acfc86b105abb2de4a04138155a7b05a30 (patch)
tree9ff15a8ea3b263dee2c8f0d54b21178d5dfb3f3a /nonprism/kipi-plugins/PKGBUILD
parent224a97af32b58295e8b37df6dce1077e32579028 (diff)
downloadabslibre-1686b7acfc86b105abb2de4a04138155a7b05a30.tar.gz
abslibre-1686b7acfc86b105abb2de4a04138155a7b05a30.tar.bz2
abslibre-1686b7acfc86b105abb2de4a04138155a7b05a30.zip
kipi-plugins-5.4.0-1.parabola1{,.nonprism1}: updating version
Diffstat (limited to 'nonprism/kipi-plugins/PKGBUILD')
-rw-r--r--nonprism/kipi-plugins/PKGBUILD81
1 files changed, 0 insertions, 81 deletions
diff --git a/nonprism/kipi-plugins/PKGBUILD b/nonprism/kipi-plugins/PKGBUILD
deleted file mode 100644
index 350fc1b7e..000000000
--- a/nonprism/kipi-plugins/PKGBUILD
+++ /dev/null
@@ -1,81 +0,0 @@
-# $Id: PKGBUILD 281957 2016-11-22 21:59:52Z arojas $
-# Maintainer (Arch): Ronald van Haren <ronald@archlinux.org>
-# Contributor (Arch): Andrea Scarpino <andrea@archlinux.org>
-# Contributor (Arch): Tobias Powalowski <tpowa@archlinux.org>
-# Maintainer: André Silva <emulatorman@parabola.nu>
-# Contributor: Márcio Silva <coadde@parabola.nu>
-
-pkgbase=digikam
-pkgname=kipi-plugins
-_pkgver=5.3.0
-pkgver=${_pkgver//-/_} # for beta versions
-pkgrel=6.parabola1.nonprism1
-pkgdesc="Digital photo management application for KDE"
-arch=('i686' 'x86_64' 'armv7h')
-license=('GPL')
-url="http://www.digikam.org/"
-replaces=("${pkgname}-libre" "${pkgname}-libre-nonprism")
-conflicts=("${pkgname}-libre" "${pkgname}-libre-nonprism")
-makedepends=('extra-cmake-modules' 'libkipi' 'libksane' 'liblqr' 'opencv' 'boost'
- 'doxygen' 'lensfun' 'eigen' 'kdoctools' 'marble' 'kdesignerplugin'
- 'kfilemetadata' 'akonadi-contacts' 'qt5-multimedia' 'threadweaver' 'kcalcore'
- 'knotifyconfig' 'libmediawiki' 'libkvkontakte')
-source=("http://download.kde.org/stable/${pkgbase}/${pkgbase}-${_pkgver}.tar.xz"
- "libre.patch"
- "nonprism.patch"
- '0001-optionally-enable-OpenGL.patch')
-sha1sums=('3a62f6efdfafc37341626cbf0225cd7adc9d0633'
- 'edd5b5eeae7ed4139b4c5f6a8446990f1da2e544'
- '246366b6b4b315957387938d842112e1146b9495'
- '95169d438884b1650a4c11e1ca44ae7ad5096a89')
-
-prepare() {
- mkdir -p build
-
- cd ${pkgbase}-${_pkgver}
- patch -p1 -i ../libre.patch
- patch -p1 -i ../nonprism.patch
-
- # OpenGL switch
- if [[ "$CARCH" = arm* ]]; then
- cd core
- patch -p1 -i ${srcdir}/0001-optionally-enable-OpenGL.patch
- fi
-}
-
-build() {
- cd build
-
- if [[ "$CARCH" = arm* ]]; then
- local cmake_extra="-DENABLE_OPENGL=OFF"
- fi
-
- cmake ../${pkgbase}-${_pkgver} \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DCMAKE_BUILD_TYPE=Release \
- -DBUILD_TESTING=OFF \
- -DENABLE_KFILEMETADATASUPPORT=ON \
- -DENABLE_MEDIAPLAYER=ON \
- -DENABLE_AKONADICONTACTSUPPORT=ON \
- -DENABLE_MYSQLSUPPORT=ON \
- -DENABLE_OPENCV3=ON \
- -DENABLE_APPSTYLES=ON \
- -DDIGIKAMSC_COMPILE_LIBKVKONTAKTE=OFF \
- $cmake_extra
- make
-}
-
-package_kipi-plugins() {
- pkgdesc="A collection of plugins extending the KDE graphics and image applications as digiKam, without nonfree suggestions and support for unsafe and dangerous for privacy protocols"
- depends=('kio' 'libkipi')
- optdepends=('libmediawiki: MediaWiki Export plugin')
-
- cd build/extra
- make DESTDIR="$pkgdir" install
- cd $srcdir/build/po
- make DESTDIR="$pkgdir" install
-
-# Provided by digikam
- rm "$pkgdir"/usr/share/locale/*/LC_MESSAGES/digikam.mo
-}