summaryrefslogtreecommitdiff
path: root/nonprism/icedove/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Grapentin <andreas@grapentin.org>2018-04-03 08:59:23 +0200
committerAndreas Grapentin <andreas@grapentin.org>2018-04-03 08:59:23 +0200
commit64175ef181a5dbdd495a16ce943503d152e3bf9c (patch)
tree291a55a3465858691d8e99c1c166b8060dda306e /nonprism/icedove/PKGBUILD
parentbd7cc65571680a1e27bfb4ed95944bcd0ef84cf7 (diff)
downloadabslibre-64175ef181a5dbdd495a16ce943503d152e3bf9c.tar.gz
abslibre-64175ef181a5dbdd495a16ce943503d152e3bf9c.tar.bz2
abslibre-64175ef181a5dbdd495a16ce943503d152e3bf9c.zip
nonprism/icedove: updated to 52.7.0
Diffstat (limited to 'nonprism/icedove/PKGBUILD')
-rw-r--r--nonprism/icedove/PKGBUILD38
1 files changed, 21 insertions, 17 deletions
diff --git a/nonprism/icedove/PKGBUILD b/nonprism/icedove/PKGBUILD
index 3affe1d4b..f639beffe 100644
--- a/nonprism/icedove/PKGBUILD
+++ b/nonprism/icedove/PKGBUILD
@@ -20,35 +20,40 @@
_pkgname=thunderbird
pkgname=icedove
epoch=1
-pkgver=52.6.0
-pkgrel=2.nonprism1
+pkgver=52.7.0
+pkgrel=2
+pkgrel+=.nonprism1
_bver=52.1
_brel=1
-pkgdesc="Libre standalone mail and news reader based on Mozilla Thunderbird, without support for unsafe and dangerous for privacy protocols"
-arch=(x86_64 i686 armv7h)
+pkgdesc="Libre standalone mail and news reader based on Mozilla Thunderbird"
+pkgdesc+=", without support for unsafe and dangerous for privacy protocols"
+arch=(x86_64)
+arch+=(i686 armv7h)
license=(MPL GPL LGPL)
url="https://wiki.parabola.nu/$pkgname"
depends=(gtk3 gtk2 mozilla-common libxt startup-notification mime-types dbus-glib alsa-lib ffmpeg
nss hunspell sqlite ttf-font icu libvpx)
makedepends=(unzip zip diffutils python2 yasm mesa imake gconf libpulse inetutils xorg-server-xvfb
- autoconf2.13 rust clang llvm quilt mozilla-searchplugins python2-blessings)
+ autoconf2.13 rust clang llvm)
+makedepends+=(quilt mozilla-searchplugins python2-blessings)
optdepends=('libcanberra: sound support')
replaces=("$_pkgname")
conflicts=("$_pkgname")
options=(!emptydirs !makeflags)
source=(https://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/$pkgver/source/thunderbird-$pkgver.source.tar.xz
+ $pkgname.desktop
0001-Bug-1338655-Don-t-try-to-build-mp4parse-bindings.-r-.patch
- no-crmf.diff rust-i686.patch fix-wifi-scanner.diff
- $pkgname.desktop $pkgname-install-dir.patch
- https://repo.parabola.nu/other/icedove/${pkgname}_$_bver-$_brel.branding.tar.xz{,.sig}
- libre.patch)
-sha256sums=('16215fb5a3765c7e5a40eadc1f3aed6918294f6d8ef1552d2aa37656055045a8'
+ rust-i686.patch fix-wifi-scanner.diff
+ $pkgname-install-dir.patch no-crmf.diff)
+source+=(https://repo.parabola.nu/other/icedove/${pkgname}_$_bver-$_brel.branding.tar.xz{,.sig}
+ libre.patch)
+sha256sums=('82462890d393ed78c03226924a6166596b7b6d1562b5071e713a7558cd292ea3'
+ 'af8199a12ebe09189d143458bd1e2d0071aff3410ed121dc2329a448a56632f0'
'413cd6d366d78f325d80ebebccfd0afa0d266b40b2e54b66ba2fa03c15f3ea67'
- '9bb0ec0d1b267f8cc1f08fbd82666459a21e4c171d52b8314b80979c948d96ce'
'f61ea706ce6905f568b9bdafd1b044b58f20737426f0aa5019ddb9b64031a269'
'9765bca5d63fb5525bbd0520b7ab1d27cabaed697e2fc7791400abc3fa4f13b8'
- 'af8199a12ebe09189d143458bd1e2d0071aff3410ed121dc2329a448a56632f0'
'a3f2431a6e9eb01d3e20dfa5110e769180b4a752ea834c1162088aa90d99e8f3'
+ 'a7317caba56e89932bd9e3b9352d94701dd9a419685057f238b1ded8dc0adcd7'
'246418976524fbead5b99e6227f97322f8d4c45e0edf9ce75561ae8eccdefc65'
'SKIP'
'4a09569394f1b4e154fdcd53f2947b7be7f065baaa31c964629dff9117fdf49b')
@@ -91,17 +96,16 @@ ac_add_options --enable-update-channel=release
ac_add_options --with-distribution-id=nu.parabola
# System libraries
-ac_add_options --with-system-nspr
-ac_add_options --with-system-nss
-ac_add_options --with-system-icu
-ac_add_options --with-system-jpeg
ac_add_options --with-system-zlib
ac_add_options --with-system-bz2
+ac_add_options --with-system-icu
+ac_add_options --with-system-jpeg
ac_add_options --with-system-libvpx
+ac_add_options --with-system-nspr
+ac_add_options --with-system-nss
ac_add_options --enable-system-hunspell
ac_add_options --enable-system-sqlite
ac_add_options --enable-system-ffi
-ac_add_options --enable-system-pixman
# Features
ac_add_options --enable-alsa