summaryrefslogtreecommitdiff
path: root/nonprism/gthumb/PKGBUILD
diff options
context:
space:
mode:
authorFreemor <freemor@freemor.ca>2020-01-23 21:17:20 -0400
committerFreemor <freemor@freemor.ca>2020-01-23 21:17:20 -0400
commit320542f52d5672f456a61e6032eb613b62927f81 (patch)
tree0edabfffa5e22678c9745dba9e0efc2ee0ad4be2 /nonprism/gthumb/PKGBUILD
parent150a0414573fa113eadedd4f3dc9aef1c27839ce (diff)
downloadabslibre-320542f52d5672f456a61e6032eb613b62927f81.tar.gz
abslibre-320542f52d5672f456a61e6032eb613b62927f81.tar.bz2
abslibre-320542f52d5672f456a61e6032eb613b62927f81.zip
Bring [nonprism/gthumb] current.
Diffstat (limited to 'nonprism/gthumb/PKGBUILD')
-rw-r--r--nonprism/gthumb/PKGBUILD31
1 files changed, 12 insertions, 19 deletions
diff --git a/nonprism/gthumb/PKGBUILD b/nonprism/gthumb/PKGBUILD
index 59c97ba8d..10cc92244 100644
--- a/nonprism/gthumb/PKGBUILD
+++ b/nonprism/gthumb/PKGBUILD
@@ -10,27 +10,26 @@
# - removed support for possibly unsafe protocols
pkgname=gthumb
-pkgver=3.6.2
-pkgrel=1.nonprism1
+pkgver=3.8.3
+pkgrel=1
+pkgrel+=.nonprism1
pkgdesc="Image browser and viewer for the GNOME Desktop, without support for unsafe and dangerous for privacy protocols"
url="https://wiki.gnome.org/Apps/gthumb"
arch=(x86_64 i686 armv7h)
license=(GPL)
depends=(dconf librsvg clutter-gtk gst-plugins-base-libs gsettings-desktop-schemas libwebp
libsecret libsoup webkit2gtk json-glib gtk3-print-backends)
-makedepends=(intltool libchamplain exiv2 itstool brasero libraw liboauth docbook-xsl
- yelp-tools flex gnome-common git)
-options=(debug !strip)
+makedepends=(libchamplain exiv2 brasero libraw liboauth docbook-xsl yelp-tools meson git)
optdepends=('libraw: read RAW files'
'exiv2: metadata support'
'libchamplain: map viewer'
'brasero: burn discs'
'liboauth: web albums')
-_commit=28f951e14aae66b96d7a03aa887ca3844824cecb # tags/3.6.2^0
+_commit=ca8f528209ab78935c30e42fe53bdf1a24f3cb44 # tags/3.8.3^0
source=("git+https://gitlab.gnome.org/GNOME/gthumb.git#commit=$_commit"
nonprism.patch)
sha256sums=('SKIP'
- 'cdc1c15a5c62f3b6ae26f26badbcdb0a2e6dacac2b46037643a919065e8221a4')
+ 'ec0e5fdf9b7d48b90821e9ce9f7fdacc60fd843183c27479854d33f457805796')
pkgver() {
cd $pkgname
@@ -39,25 +38,19 @@ pkgver() {
prepare() {
cd $pkgname
- patch -Np1 -i ../nonprism.patch
- NOCONFIGURE=1 ./autogen.sh
+ patch --verbose -Np1 -i ../nonprism.patch # Set meson_options to build without webservices
+ rm ./data/icons/private/hicolor/16x16/actions/site-*.png # Get rid of the logos
}
build() {
- cd $pkgname
- ./configure --prefix=/usr --sysconfdir=/etc \
- --localstatedir=/var --disable-static \
- --enable-libchamplain
- sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
- make
+ arch-meson $pkgname build -D libchamplain=true
+ ninja -C build
}
check() {
- cd $pkgname
- make check
+ meson test -C build --print-errorlogs
}
package() {
- cd $pkgname
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" meson install -C build
}