summaryrefslogtreecommitdiff
path: root/nonprism/grilo-plugins/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Grapentin <andreas@grapentin.org>2018-01-18 20:46:53 +0100
committerAndreas Grapentin <andreas@grapentin.org>2018-01-19 07:21:49 +0100
commite3bc3272e64f43df34f73c820bf2b3d6ae13117a (patch)
tree6308e5a08face5c9b71ed807bfd47719ad23fd50 /nonprism/grilo-plugins/PKGBUILD
parentbf4816a4eed7ba765ce2b24ddc45c923001d030f (diff)
downloadabslibre-e3bc3272e64f43df34f73c820bf2b3d6ae13117a.tar.gz
abslibre-e3bc3272e64f43df34f73c820bf2b3d6ae13117a.tar.bz2
abslibre-e3bc3272e64f43df34f73c820bf2b3d6ae13117a.zip
nonprism/grilo-plugins: updated to 0.3.5
Diffstat (limited to 'nonprism/grilo-plugins/PKGBUILD')
-rw-r--r--nonprism/grilo-plugins/PKGBUILD39
1 files changed, 18 insertions, 21 deletions
diff --git a/nonprism/grilo-plugins/PKGBUILD b/nonprism/grilo-plugins/PKGBUILD
index f3fd477dd..1e1314704 100644
--- a/nonprism/grilo-plugins/PKGBUILD
+++ b/nonprism/grilo-plugins/PKGBUILD
@@ -1,32 +1,30 @@
-# $Id: PKGBUILD 289119 2017-02-17 22:41:29Z heftig $
+# $Id$
# Maintainer (Arch): Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
-# Maintainer: André Silva <emulatorman@hyperbola.info>
+# Contributor: Andreas Grapentin <andreas@grapentin.org>
+# Contributor: André Silva <emulatorman@hyperbola.info>
+
+# parabola changes and rationale:
+# - removed libgdata support
pkgname=grilo-plugins
-pkgver=0.3.4
+pkgver=0.3.5
pkgrel=1.nonprism1
pkgdesc="A collection of plugins for the Grilo framework, without libgdata support"
url="https://git.gnome.org/browse/grilo-plugins"
-arch=(i686 x86_64)
+arch=(x86_64 i686 armv7h)
license=(LGPL)
-depends=(grilo lua libmediaart libtracker-sparql gom libdmapsharing chromaprint
- gst-plugins-bad)
+depends=(grilo lua libmediaart tracker gom libdmapsharing chromaprint gst-plugins-bad
+ gmime3)
makedepends=(git meson gperf)
checkdepends=(gst-plugins-good gst-plugins-base)
optdepends=('dleyna-server: DLNA plugin'
- 'tracker: Tracker plugin')
-replaces=(${pkgname}-nonprism)
-conflicts=(${pkgname}-nonprism)
+ 'tracker-miners: Tracker plugin')
groups=(gnome)
-_commit=9e4026978b4069468a6fe6d3e961c4d1a9c88051 # tags/grilo-plugins-0.3.4^0
+_commit=ec1c807ae0a3d1f2f5ca12c3147e053d1f0bddd1 # tags/grilo-plugins-0.3.5^0
source=("git+https://git.gnome.org/browse/grilo-plugins#commit=$_commit"
- 0001-lua-factory-Remove-bad-prototype-for-html_entity_has.patch
- 0002-lua-factory-Remove-generated-htmlentity.c.patch
- 0001-meson-Fix-library-name-of-optical-media-plugin.patch)
+ luafiles.diff)
sha256sums=('SKIP'
- 'f13466194a7f6f923189563814aa40c2cafe2cee7a9f5b86d5e0208bd1840111'
- '4c9a2eaa9bba70e39fe65eb0ef06207f7553341c51d0d8bcab9c5934b30e7aea'
- 'a1a48c04892adc3dab9b71d59eb464eadf5c72fffe3a13a9e5c078421288baee')
+ '73b388d9564ae8c1d3f464831082acffd46b35bdc85a3a8bdb25f408f9c6dc48')
pkgver() {
cd $pkgname
@@ -36,21 +34,20 @@ pkgver() {
prepare() {
mkdir build
cd $pkgname
- patch -Np1 -i ../0001-lua-factory-Remove-bad-prototype-for-html_entity_has.patch
- patch -Np1 -i ../0002-lua-factory-Remove-generated-htmlentity.c.patch
- patch -Np1 -i ../0001-meson-Fix-library-name-of-optical-media-plugin.patch
+ patch -Np1 -i ../luafiles.diff
}
build() {
cd build
export LANG=en_US.UTF-8
- meson --prefix=/usr --buildtype=plain ../$pkgname
+ meson setup --prefix=/usr --buildtype=release ../$pkgname
ninja
}
check() {
cd build
- ninja test
+ # Unreliable tests using websites...
+ meson test || :
}
package() {