summaryrefslogtreecommitdiff
path: root/nonprism/gnome-settings-daemon/PKGBUILD
diff options
context:
space:
mode:
authorOmar Vega Ramos <ovruni@gnu.org.pe>2019-08-13 13:09:34 -0500
committerOmar Vega Ramos <ovruni@gnu.org.pe>2019-08-13 13:09:34 -0500
commit8e78ba2455def0812560c1ca23c470c3c4e8fd8f (patch)
tree429634d3d4e4fd75a0431c3faef4eae7622cefef /nonprism/gnome-settings-daemon/PKGBUILD
parent54caeeb5ef363e2033730e24264faeb437aa16f0 (diff)
downloadabslibre-8e78ba2455def0812560c1ca23c470c3c4e8fd8f.tar.gz
abslibre-8e78ba2455def0812560c1ca23c470c3c4e8fd8f.tar.bz2
abslibre-8e78ba2455def0812560c1ca23c470c3c4e8fd8f.zip
gnome-settings-daemon-3.32.1-1.nonprism1: updating version
Diffstat (limited to 'nonprism/gnome-settings-daemon/PKGBUILD')
-rw-r--r--nonprism/gnome-settings-daemon/PKGBUILD48
1 files changed, 23 insertions, 25 deletions
diff --git a/nonprism/gnome-settings-daemon/PKGBUILD b/nonprism/gnome-settings-daemon/PKGBUILD
index d9ff56073..7937370c4 100644
--- a/nonprism/gnome-settings-daemon/PKGBUILD
+++ b/nonprism/gnome-settings-daemon/PKGBUILD
@@ -1,31 +1,34 @@
-# $Id$
# Maintainer (Arch): Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
-# Contributor: Andreas Grapentin <andreas@grapentin.org>
-# Contributor: André Silva <emulatorman@hyperbola.info>
+# Contributor (Hyperbola): Andreas Grapentin <andreas@grapentin.org>
+# Contributor (Hyperbola): André Silva <emulatorman@hyperbola.info>
# Contributor: Isaac David <isacdaavid@at@isacdaavid.info>
+# Contributor: Omar Vega Ramos <ovruni@gnu.org.pe>
# parabola changes and rationale:
# - removed geoclue2 support
pkgname=gnome-settings-daemon
-pkgver=3.26.2
-pkgrel=1.nonprism1
+pkgver=3.32.1
+pkgrel=1
+pkgrel+=.nonprism1
pkgdesc="GNOME Settings Daemon, without geoclue2 support"
-url="https://git.gnome.org/browse/gnome-settings-daemon"
-arch=(x86_64 i686 armv7h)
+url="https://gitlab.gnome.org/GNOME/gnome-settings-daemon"
+arch=(x86_64)
+arch+=(i686 armv7h)
license=(GPL)
-depends=(dconf gnome-desktop gsettings-desktop-schemas libcanberra-pulse libnotify libsystemd
+depends=(dconf gnome-desktop gsettings-desktop-schemas libcanberra-pulse libnotify systemd-libs
libwacom pulseaudio pulseaudio-alsa upower librsvg libgweather geocode-glib nss
libgudev gtk3-print-backends libnm)
-makedepends=(intltool xf86-input-wacom libxslt docbook-xsl python git gnome-common)
+makedepends=(xf86-input-wacom libxslt docbook-xsl python git meson)
+checkdepends=(python-gobject python-dbusmock)
groups=(gnome)
-_commit=b4a1b1ab4da2be6628811a763376fc39c116cdbe # tags/GNOME_SETTINGS_DAEMON_3_26_2^0
-source=("git+https://git.gnome.org/browse/gnome-settings-daemon#commit=$_commit"
- "git+https://git.gnome.org/browse/libgnome-volume-control"
+_commit=57114085a09e86968e0a0261392c6866352f35fd # tags/GNOME_SETTINGS_DAEMON_3_32_1^0
+source=("git+https://gitlab.gnome.org/GNOME/gnome-settings-daemon.git#commit=$_commit"
+ "git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git"
nonprism.patch)
sha256sums=('SKIP'
'SKIP'
- '6ac18c459d9d2541be9bf9cf94f31c844920dd627f82c159d43490bb6f905ad4')
+ '6619205eb1e4d87caeb8e1673d6c80acf4d30f15ae91c5f6cb728a2e5674bf65')
pkgver() {
cd $pkgname
@@ -36,26 +39,21 @@ prepare() {
cd $pkgname
git submodule init
- git config --local submodule."panels/media-keys/gvc".url "$srcdir/libgnome-volume-control"
+ git config --local submodule.subprojects/gvc.url "$srcdir/libgnome-volume-control"
git submodule update
patch -p1 -i $srcdir/nonprism.patch
- NOCONFIGURE=1 ./autogen.sh
}
build() {
- cd $pkgname
-
- ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
- --libexecdir=/usr/lib/$pkgname --disable-static
-
- #https://bugzilla.gnome.org/show_bug.cgi?id=656231
- sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+ arch-meson $pkgname build
+ ninja -C build
+}
- make
+check() {
+ meson test -C build
}
package() {
- cd $pkgname
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" meson install -C build
}