summaryrefslogtreecommitdiff
path: root/nonprism/eog-plugins/PKGBUILD
diff options
context:
space:
mode:
authorcoadde [Márcio Alexandre Silva Delgado] <coadde@parabola.nu>2014-09-04 02:25:14 -0300
committercoadde [Márcio Alexandre Silva Delgado] <coadde@parabola.nu>2014-09-04 02:25:14 -0300
commitfc353061e3e6b3e8542d2000b89ca2ecfc604b1b (patch)
tree615f9efcdc5cf45213866013e12c2293f69e2a69 /nonprism/eog-plugins/PKGBUILD
parent0873eff3fe57c9e108ef0cf5f5b700bbb449629a (diff)
parent448c73d26577be3e04afda7364e3a7b3782b64cc (diff)
downloadabslibre-fc353061e3e6b3e8542d2000b89ca2ecfc604b1b.tar.gz
abslibre-fc353061e3e6b3e8542d2000b89ca2ecfc604b1b.tar.bz2
abslibre-fc353061e3e6b3e8542d2000b89ca2ecfc604b1b.zip
Merge branch 'master' of ssh://lukeshu.com:1863/srv/git/mirror/parabola/abslibre
Diffstat (limited to 'nonprism/eog-plugins/PKGBUILD')
-rw-r--r--nonprism/eog-plugins/PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/nonprism/eog-plugins/PKGBUILD b/nonprism/eog-plugins/PKGBUILD
new file mode 100644
index 000000000..78ff2bd78
--- /dev/null
+++ b/nonprism/eog-plugins/PKGBUILD
@@ -0,0 +1,36 @@
+# $Id: PKGBUILD 210576 2014-04-15 08:00:45Z jgc $
+# Maintainer (Arch): Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Maintainer: Márcio Silva <coadde@parabola.nu>
+
+pkgname=eog-plugins
+pkgver=3.12.1
+pkgrel=1.nonprism1
+pkgdesc="Plugins for Eye of Gnome, without libgdata support"
+arch=('i686' 'x86_64' 'mips64el')
+url="https://wiki.gnome.org/Apps/EyeOfGnome/Plugins"
+license=('GPL2')
+depends=('eog' 'libchamplain')
+makedepends=('intltool')
+conflicts=(${pkgname}-nonprism)
+replaces=(${pkgname}-nonprism)
+install=eog-plugins.install
+source=(http://download.gnome.org/sources/$pkgname/${pkgver:0:4}/$pkgname-$pkgver.tar.xz)
+sha256sums=('5b9a6854d5411e75aadb9d44694bbe02a35f5a79a23da5c1bb4feb6bacf56f1c')
+
+build() {
+ cd $pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc --localstatedir=/var
+
+ # https://bugzilla.gnome.org/show_bug.cgi?id=655517
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et: