summaryrefslogtreecommitdiff
path: root/nonprism/empathy/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Grapentin <andreas@grapentin.org>2018-01-19 07:20:35 +0100
committerAndreas Grapentin <andreas@grapentin.org>2018-01-19 07:21:49 +0100
commitd3c5d6439541b49412effb12552c4654f8cdfac7 (patch)
tree79972c50a41692877c8cd74d92d326bee4a6592e /nonprism/empathy/PKGBUILD
parente3bc3272e64f43df34f73c820bf2b3d6ae13117a (diff)
downloadabslibre-d3c5d6439541b49412effb12552c4654f8cdfac7.tar.gz
abslibre-d3c5d6439541b49412effb12552c4654f8cdfac7.tar.bz2
abslibre-d3c5d6439541b49412effb12552c4654f8cdfac7.zip
nonprism/empathy: updated to 3.25.90+34+g78f4d4fda
Diffstat (limited to 'nonprism/empathy/PKGBUILD')
-rw-r--r--nonprism/empathy/PKGBUILD24
1 files changed, 15 insertions, 9 deletions
diff --git a/nonprism/empathy/PKGBUILD b/nonprism/empathy/PKGBUILD
index 0eae9cf62..c7b7c003c 100644
--- a/nonprism/empathy/PKGBUILD
+++ b/nonprism/empathy/PKGBUILD
@@ -1,13 +1,17 @@
-# $Id: PKGBUILD 290827 2017-03-14 10:00:45Z heftig $
+# $Id$
# Contributor (Arch): Ionut Biru <ibiru@archlinux.org>
+# Contributor: Andreas Grapentin <andreas@grapentin.org>
# Contributor: André Silva <emulatorman@hyperbola.info>
+# parabola changes and rationale
+# - removed geoclue2 support
+
pkgname=empathy
-pkgver=3.12.12+111+g3300c6deb
-pkgrel=1.nonprism2
+pkgver=3.25.90+34+g78f4d4fda
+pkgrel=3.nonprism1
pkgdesc="A GNOME instant messaging client using the Telepathy framework, without geoclue2 support"
url="https://wiki.gnome.org/Apps/Empathy"
-arch=(i686 x86_64)
+arch=(x86_64 i686 armv7h)
license=(GPL2)
depends=(clutter-gst clutter-gtk folks gcr iso-codes libcanberra libpulse webkit2gtk
telepathy-farstream telepathy-glib telepathy-logger telepathy-mission-control
@@ -16,14 +20,14 @@ makedepends=(intltool itstool docbook-xsl python gnome-common git)
optdepends=('telepathy-gabble: XMPP/Jabber support'
'telepathy-idle: IRC support'
'telepathy-salut: Link-local XMPP support'
- 'telepathy-rakia: SIP support'
'telepathy-haze: libpurple support')
-groups=(gnome)
-_commit=3300c6deb7be1209ca38657c03e15ea729df2ae9 # master
+_commit=78f4d4fdadd7da67e063c2905649f6a6015ef8f9 # master
source=("git+https://git.gnome.org/browse/empathy#commit=$_commit"
- "git+https://git.gnome.org/browse/telepathy-account-widgets")
+ "git+https://git.gnome.org/browse/telepathy-account-widgets"
+ enchant-2.patch)
sha256sums=('SKIP'
- 'SKIP')
+ 'SKIP'
+ 'f177f0dfc242018dd52e312637f513fd08f64aa991b45930cc3ea9a2576f795e')
pkgver() {
cd $pkgname
@@ -37,6 +41,8 @@ prepare() {
git config --local submodule.telepathy-account-widgets.url "$srcdir/telepathy-account-widgets"
git submodule update
+ patch -Np1 -i ../enchant-2.patch
+
NOCONFIGURE=1 ./autogen.sh
}