summaryrefslogtreecommitdiff
path: root/nonprism/claws-mail/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2015-01-02 04:05:36 -0200
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2015-01-02 04:05:36 -0200
commitd2ff5a481eeb671f9b09e41214509579642f57e9 (patch)
tree32b848080dea94a7fc9702aef5b7412e141d602d /nonprism/claws-mail/PKGBUILD
parent5bb589381787cfe0dbfe3cb8c4ca821ba5989e60 (diff)
downloadabslibre-d2ff5a481eeb671f9b09e41214509579642f57e9.tar.gz
abslibre-d2ff5a481eeb671f9b09e41214509579642f57e9.tar.bz2
abslibre-d2ff5a481eeb671f9b09e41214509579642f57e9.zip
claws-mail-3.11.1-1.nonprism1: updating version
Diffstat (limited to 'nonprism/claws-mail/PKGBUILD')
-rw-r--r--nonprism/claws-mail/PKGBUILD24
1 files changed, 17 insertions, 7 deletions
diff --git a/nonprism/claws-mail/PKGBUILD b/nonprism/claws-mail/PKGBUILD
index f1f4e0191..66102f09e 100644
--- a/nonprism/claws-mail/PKGBUILD
+++ b/nonprism/claws-mail/PKGBUILD
@@ -1,17 +1,17 @@
-# $Id: PKGBUILD 225145 2014-10-21 15:34:17Z andyrtr $
+# $Id: PKGBUILD 228325 2015-01-01 12:49:11Z andyrtr $
# Maintainer (Arch): Andreas Radke <andyrtr@archlinux.org>
# Maintainer: Márcio Silva <coadde@parabola.nu>
pkgname=claws-mail
-pkgver=3.11.0
-pkgrel=2.nonprism1
+pkgver=3.11.1
+pkgrel=1.nonprism1
pkgdesc="A GTK+ based e-mail client, without libgdata support"
arch=('i686' 'x86_64' 'mips64el')
license=('GPL3')
url="http://www.$pkgname.org"
depends=('gtk2' 'gnutls' 'startup-notification' 'enchant' 'gpgme' 'libetpan' 'compface'
'libsm' 'dbus-glib' 'hicolor-icon-theme' 'desktop-file-utils')
-makedepends=('spamassassin' 'bogofilter' 'valgrind' 'intltool'
+makedepends=('spamassassin' 'bogofilter' 'valgrind'
# dependencies for plugins
'libsoup' 'webkitgtk2' 'libnotify' 'libcanberra' 'poppler-glib' 'pygtk')
#'libchamplain' needed for geolocation plugin, disabled for now - most time it's not compatible with current gnome releases
@@ -34,9 +34,19 @@ replaces=("sylpheed-claws" "$pkgname-extra-plugins" "$pkgname-libre" "$pkgname-l
conflicts=("$pkgname-extra-plugins" "$pkgname-libre" "$pkgname-libre-nonprism" "$pkgname-nonprism")
provides=('claws')
install=$pkgname.install
-source=(http://downloads.sourceforge.net/sourceforge/claws-mail/$pkgname-$pkgver.tar.xz{,.asc})
-sha1sums=('1fc919e7d4357408a04131c4195878ea920de4f0'
- 'SKIP')
+source=(http://downloads.sourceforge.net/sourceforge/claws-mail/$pkgname-$pkgver.tar.xz{,.asc}
+ git_fixes.diff)
+sha1sums=('b0c07906043f7a3ec726c7a96d6dcfc3c148b9cc'
+ 'SKIP'
+ '0e1bd9d696d531040f7b15b5b6164fc44784fdfc')
+validpgpkeys=('8B3B297A03468356692F8D592CD716D654D6BBD4') # Paul <paul@claws-mail.org>
+
+prepare() {
+ cd $pkgname-$pkgver
+ # fix .desktop file creation
+ patch -Np1 -i $srcdir/git_fixes.diff
+ autoreconf -vfi
+}
build() {
cd $pkgname-$pkgver