summaryrefslogtreecommitdiff
path: root/nonprism/claws-mail/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Grapentin <andreas@grapentin.org>2018-01-20 06:33:31 +0100
committerAndreas Grapentin <andreas@grapentin.org>2018-01-20 06:33:31 +0100
commit53fca468b1abfd168acf249b2ed2ff95410fdaa3 (patch)
tree23b64da75f1793ca51cde363b3f2d6f07507f2ca /nonprism/claws-mail/PKGBUILD
parentaf21b330575fd55d3e8092fd286141e55cdcb090 (diff)
downloadabslibre-53fca468b1abfd168acf249b2ed2ff95410fdaa3.tar.gz
abslibre-53fca468b1abfd168acf249b2ed2ff95410fdaa3.tar.bz2
abslibre-53fca468b1abfd168acf249b2ed2ff95410fdaa3.zip
nonprism/claws-mail: updated to 3.16.0
Diffstat (limited to 'nonprism/claws-mail/PKGBUILD')
-rw-r--r--nonprism/claws-mail/PKGBUILD59
1 files changed, 27 insertions, 32 deletions
diff --git a/nonprism/claws-mail/PKGBUILD b/nonprism/claws-mail/PKGBUILD
index 826b4b9e1..19903cf81 100644
--- a/nonprism/claws-mail/PKGBUILD
+++ b/nonprism/claws-mail/PKGBUILD
@@ -1,24 +1,25 @@
-# Maintainer: Andreas Grapentin <andreas@grapentin.org>
+# $Id$
# Maintainer (Arch): Andreas Radke <andyrtr@archlinux.org>
+# Contributor: Andreas Grapentin <andreas@grapentin.org>
# Contributor: Márcio Silva <coadde@hyperbola.info>
-pkgname=claws-mail
-
-pkgver=3.15.1
-pkgrel=3.nonprism2
-arch=(i686 x86_64 armv7h)
+# parabola changes and rationale:
+# - removed libgdata support
+pkgname=claws-mail
+pkgver=3.16.0
+pkgrel=2.nonprism1
pkgdesc="A GTK+ based e-mail client, without libgdata support"
+arch=('x86_64' 'i686' 'armv7h')
+license=('GPL3')
url="http://www.claws-mail.org"
-license=(GPL3)
-
-depends=(gtk2 gnutls startup-notification enchant gpgme libetpan compface
- libsm dbus-glib hicolor-icon-theme desktop-file-utils)
-makedepends=(spamassassin bogofilter valgrind
+depends=('gtk2' 'gnutls' 'startup-notification' 'enchant' 'gpgme' 'libetpan' 'compface'
+ 'libsm' 'dbus-glib' 'hicolor-icon-theme' 'desktop-file-utils')
+makedepends=('spamassassin' 'bogofilter' 'valgrind'
# dependencies for plugins
- libnotify libcanberra poppler-glib pygtk libytnef libical dillo
+ 'libnotify' 'libcanberra' 'poppler-glib' 'pygtk' 'libytnef' 'libical' 'dillo'
# deps to build the docs
- docbook-utils)
+ 'docbook-utils')
#'libchamplain' needed for geolocation plugin, disabled for now - most time it's not compatible with current gnome releases
optdepends=('python2: needed for some tools and python plugin'
'perl: needed for some tools and perl plugin'
@@ -35,34 +36,28 @@ optdepends=('python2: needed for some tools and python plugin'
'ghostscript: for pdf viewer plugin'
'libical: for vcalendar plugin'
'dillo: for html viewer plugin')
-replaces=(sylpheed-claws claws-mail-extra-plugins claws-mail-libre claws-mail-libre-nonprism claws-mail-nonprism)
-conflicts=(claws-mail-extra-plugins claws-mail-libre claws-mail-libre-nonprism claws-mail-nonprism)
-provides=(claws)
-
+replaces=('sylpheed-claws' 'claws-mail-extra-plugins')
+conflicts=('claws-mail-extra-plugins')
+provides=('claws')
source=(http://www.claws-mail.org/download.php?file=releases/claws-mail-$pkgver.tar.xz{,.asc}
- dillo-plugin.diff
- enchant-2.patch
- claws-mail-3.15.1-libical3.patch)
-sha256sums=('8d093c2f32db863c1141d56e35424c04ee48fe5d6adf4c7f349f647fa3149542'
+ dillo-plugin.diff)
+sha256sums=('c212133d3d962129d8c7995c1c7d973faef2a8914481c0c74578217bf4c897ab'
'SKIP'
- '4913d101aa32a69afda7ffb17eb23dce8580bfb619e28cc271f4ea10ce39cc5d'
- 'fafd9713b265b55a84b01e5071d930965b98d34cde57be4aaa46c5eb6c2635ce'
- '160cb7a3ac057c5a8f65427adc152f53abd372eeaf1b371e9a99bfcb741a793f')
+ 'ab08ca513145e847d30a29d9e5a9ae63b94222423e88c1b375fd5cfcb427d6c5')
validpgpkeys=('8B3B297A03468356692F8D592CD716D654D6BBD4') # Paul <paul@claws-mail.org>
prepare() {
- cd $pkgname-$pkgver
+ cd ${pkgname}-${pkgver}
# upstream reintroduction of dillo plugin - after fancy plugin dropped
patch -Np1 -i ../dillo-plugin.diff
- patch -Np1 -i ../enchant-2.patch
- patch -Np1 -i ../claws-mail-3.15.1-libical3.patch
+
autoreconf -vfi
sed -i 's@^#!.*python.*@#!/usr/bin/python2@' tools/*.py
sed -i 's:python -c:python2 -c:g' configure
}
build() {
- cd $pkgname-$pkgver
+ cd ${pkgname}-${pkgver}
# fixes for python2
export PYTHON="/usr/bin/python2"
@@ -81,13 +76,13 @@ build() {
}
package() {
- cd $pkgname-$pkgver
- make DESTDIR="$pkgdir" install
+ cd ${pkgname}-${pkgver}
+ make DESTDIR=${pkgdir} install
# install extra tools
cd tools
- install -m755 -d $pkgdir/usr/lib/claws-mail/tools
+ install -m755 -d ${pkgdir}/usr/lib/claws-mail/tools
for files in *.pl *.py *.sh kdeservicemenu multiwebsearch.conf tb2claws-mail update-po uudec uuooffice README; do
- cp -arv $files $pkgdir/usr/lib/claws-mail/tools/$i
+ cp -arv $files ${pkgdir}/usr/lib/claws-mail/tools/${i}
done
}